Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7113 closed defect (fixed)

DRASCULA: Serious sprite glitches

Reported by: SF/jomalin1 Owned by: criezy
Priority: normal Component: Engine: Drascula
Keywords: Cc:
Game: Drascula

Description

I am using Win7 SP1 64 bits and ScummVM 1.8.0 and the SPANISH version of Drascula.

Instead of the pendulum animation, you can see sprites of the protagonist, a serious sprite glitch. Another sprite glitch happened to me but i couldn't reproduce it again with a savegame, it was in Von Braun's house, just before entering to the noise box, the sprites walking of the protagonist were bizarre, like with incorrect pixels.

Screenshot attached with the pendulum sprite glitch.

Ticket imported from: bugs/7113.

Attachments (8)

sprite bug.png (47.5 KB ) - added by SF/jomalin1 4 years ago.
drascula-es.023 (11.3 KB ) - added by SF/jomalin1 4 years ago.
sprite bug2.png (45.6 KB ) - added by SF/jomalin1 4 years ago.
conver Dosbox.png (60.4 KB ) - added by SF/jomalin1 4 years ago.
conver ScummVM.png (63.4 KB ) - added by SF/jomalin1 4 years ago.
Dosbox font (colour as Drascula, red, correct).png (59.7 KB ) - added by SF/jomalin1 4 years ago.
ScummVM font (colour as protagonist, yellow, but must be red).png (61.1 KB ) - added by SF/jomalin1 4 years ago.
DRASCULA Dosbox savegame.rar (285 bytes ) - added by SF/jomalin1 4 years ago.

Download all attachments as: .zip

Change History (20)

by SF/jomalin1, 4 years ago

Attachment: sprite bug.png added

by SF/jomalin1, 4 years ago

Attachment: drascula-es.023 added

comment:1 by SF/jomalin1, 4 years ago

I also attach the savegame, load it and you will see the strange pendulum animation.

by SF/jomalin1, 4 years ago

Attachment: sprite bug2.png added

comment:2 by SF/jomalin1, 4 years ago

Also, the verb icons are strange in the pendulum scene, with sprites of the protagonist head in the background of each verb icon. The verb icons remains weird until the final of the game (also in the bar where Drascula and the others are)

comment:3 by criezy, 4 years ago

Owner: set to criezy
Summary: Serious sprite glitchesDRASCULA: Serious sprite glitches

comment:4 by criezy, 4 years ago

Looking at the source code there is an issue when restoring a save game in that scene when still being chained under the pendulum. The state of the game is not fully restored.

Your save game is corrupted and crashes ScummVM, which might be because you saved again after loading it (which would save the not fully restored state and thus the save would contain garbage). I managed to "fix" it by adding back correct values and then I can reproduce your sprite issue.

I have a fix for it, but I want to check it by playing up to there rather than start from your corrupted savegame.

Also I am wondering how the original behaves for example when played in DosBox. Do you know if it is possible to save, and if it is, does loading the save game works properly?

comment:5 by criezy, 4 years ago

I have now tested my fix when loading a save game I had in the previous room and opening Drascula's coffin, then saving again in the pendulum scene. I tested several language and all were broken in the same way before and are now working. So I have pushed that change and it will be in the next daily build and release.

It would be good if you can confirm that the issue for you was only when loading the same game (and that when you reach that scene from the previous room by opening the coffin it works fine).

Regarding the second glitch, with the verb and inventory icons, I suspect this is an issue with the game data, Indeed I only get that issue with the Spanish version (for example using the English game data I don't have the issue). But I only noticed that while testing the pendulum animation glitch. I will have another look at that specific issue and I am keeping this bug open until I do.

Also if you know the answer, I am still interested in how the original behaves under DosBox. And also if it has the same issue with the verb and inventory icons.

comment:6 by SF/jomalin1, 4 years ago

Thanks Thierry, you are so fast. The sprite glitch happened to me before saving, and then i saved it. And yes, maybe i saved it two times...

What was the bug? I am curious about it.

comment:7 by criezy, 4 years ago

If the pendulum sprite glitch happened before saving then there is probably a different bug.
What I fixed was that the game state was not fully restored when loading a savegame in this particular scene. For example it didn't load some of the sprites for the pendulum animation and didn't set the protagonist state properly.

This should however be done properly when getting to that scene from the animation that follows opening Drascula's coffin. So if it didn't for you, there may be a different issue, maybe for example when skipping part of that animation. I don't really see how that can happen though, so if you can give more details of what you did after opening the coffin it would help.

by SF/jomalin1, 4 years ago

Attachment: conver ScummVM.png added

comment:8 by SF/jomalin1, 4 years ago

I confirm you a thing: the sprites glitches does not happen in Dosbox spanish version.

And yes, there was another problem just before the sprite glitch. I think i have found it: on the first conversation you can start with Drascula, in Dosbox, as always, when the 4 questions you can ask are shown, your mouse has no icon, but in ScummVM, it has icon! (and this is in the only conversation it has icon, so there was something strange here).

Screenshots in ScummVM (icon) and Dosbox (no icon, this is the normal behaviour when you are selecting the sentence when speaking) attached comparing them.

comment:9 by SF/jomalin1, 4 years ago

I found even a strange behaviour before the conversation with Dracula: when opening the coffin, just the second sentence, ScummVM changes the colour of the font from Drascula (red) to yellow (that belongs to the protagonist). So it looks like the character are confused for that sentence.

Screenshots attached from Dosbox and ScummVM.

by SF/jomalin1, 4 years ago

comment:10 by SF/jomalin1, 4 years ago

SORRY, the sprite glitch also happen in the game from Dosbox!!!

This is how to reproduce it: just open the coffin, and after all the characters finished to speak and you are under the balancing pendulum, save the game. The savegame will be saved corrupted! But if you load it from the balancing pendulum, looks like is correct but it is not... (this is probably because some things loaded into memory were yet loaded). So, if you load a savegame from another scenario, that is not the balancing pendulum, and now you load the savegame from the pendulum, you will see the sprite glitch.
So, as i said, just save the game in the balancing pendulum, the savegame will be corrupted.

Dosbox savegame attached to reproduce the bug, the name is "ATAUD".

comment:11 by criezy, 4 years ago

OK. That is what I expected since I didn't see anything in the source code of the original engine to handle this properly. So that is one aspect in which we will be better than the original :)

In the meantime I have found that we indeed have a bug in ScummVM for the background of the inventory in chapter 6 in the Spanish version (all other languages are OK and all other chapters are OK). I am not sure yet how to fix it as I have several options that I need to evaluate.

I will also take a look at the mouse cursor during the dialogs and at the font color. You are adding new issues faster than I can fix them :P

comment:12 by criezy, 4 years ago

Resolution: fixed
Status: newclosed

comment:13 by criezy, 4 years ago

OK. I think I have now fixed all the issues reported in this bug. To summarize:
Fix graphical glitch in pendulum animation
Fix wrong background for inventory items.
Fix wrong text color for Drascula after opening the coffin.
Fix cursor visible during the animation in the pendulum room.
* Fix loading and saving while being chained in the pendulum room.

Thank you again for reporting those issues.

comment:14 by SF/jomalin1, 4 years ago

Thanks Thierry! You are so fast!

Will this correction also fix the sprite glitch i saw just before the protagonist walked to enter to the noise box in Von Braun's house (i talked about it in my first post)? I only saw this bug once and i could not reproduce it again.

Note: See TracTickets for help on using tickets.