Opened 4 years ago

Closed 4 years ago

#7104 closed defect (fixed)

LOL-CD: mixing sfx and voice mode does not work

Reported by: SF/bakhtosh Owned by: athrxx
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Lands of Lore

Description

ScummVM version: 1.8.0 (Feb 28 2016 11:36:21)
Language of game: english
Version of game: LOL-CD V CD1.02 D
Platform: Windows 10 64 Bit

Bug details, including instructions on reproducing it:

  • play until you encounter an enemy and fight
  • listen when you use your weapon
  • listen if you successfully hit an enemy

If you use your weapon you can always hear the weapon sfx of your weapon. Doesn't matter if you hit the enemy or not. But if you hit the enemy you should hear an additional sfx (a "voice" reaction of the enemy). And that one is always missing with ScummVM.

This ability to mix the weapon sfx and voice is described in the original README.ENG of the CD version of the game:
1.3 Mixing sound effects and voice
"Lands of Lore PC-CD-ROM" includes code that mixes sound effects
and digitized voice. Now you can hear the sword swing as the
monsters scream and you'll hear footsteps down the corridor as your
characters speak. This is automatically implemented if you
install under DOS. The WINDOWS version does not incorporate
this code.

If you play the game using DosBox mixing of sfx and voice works.

I've made two videos (one using DosBox and one using ScummVM) for comparision. The videos show the same two types of enemies (a pig and a man).
In the one using ScummVM you can only hear the weapon sfx but no enemy reaction voice if he takes a hit:
http://bakhtosh.bplaced.net/LOL/scummvm_hits.avi
In the one using DosBox you can hear the weapon sfx and the enemy reaction voice if he takes a hit (the weapon sfx is a bit harder to hear because its less loud than the enemy reatcion voice but its still noticeable):
http://bakhtosh.bplaced.net/LOL/dosbox_hits.avi

Ticket imported from: bugs/7104.

Change History (5)

comment:1 by lordhoto, 4 years ago

Owner: set to athrxx

comment:2 by athrxx, 4 years ago

Resolution: fixed
Status: newpending

comment:3 by athrxx, 4 years ago

Thank you for your report. I've committed a fix for that bug. Please test whether this works for you..

comment:4 by SF/bakhtosh, 4 years ago

I've only played from the beginning to the end of the first wood level so far using the build 1.9.0git1480-g0f55fc9 (Apr 4 2016). But up to then it works. I fear it might take a while until I can complete the game and confirm that it works till the end without any problems.

comment:5 by athrxx, 4 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.