Opened 4 years ago

Closed 4 years ago

#6936 closed defect (fixed)

I cannot open the inventory because crash the game (spanish version)

Reported by: SF/eliaorru Owned by: m-kiewitz
Priority: normal Component: Engine: Sherlock
Keywords: Cc:
Game: Sherlock Holmes: Case of the Rose Tattoo

Description

When I open the inventory during the game , it crushes and the ScummVm's window closes.

Ticket imported from: bugs/6936.

Attachments (1)

rosetattoo-es.001 (19.6 KB ) - added by SF/eliaorru 4 years ago.

Download all attachments as: .zip

Change History (9)

by SF/eliaorru, 4 years ago

Attachment: rosetattoo-es.001 added

comment:1 by dreammaster, 4 years ago

Ah, you're playing the Spanish version of the game. That explains why we couldn't replicate the problem. We're currently trying to locate a copy of the Spanish version ourselves for testing the problem, so you'll have to wait until we find one.

comment:2 by SF/eliaorru, 4 years ago

Can I send you my copy of the game in Spanish version?

comment:3 by m-kiewitz, 4 years ago

I just fixed this issue via commit 2118daef220022dcc2a86e95c27418db62450fb2. It was caused by us using the English inventory names. And that was because we didn't have Spanish hardcoded text.

You need to restart the game right from the start though. Your saved games still won't work (and will never work b/c they are effectively broken).

And may I ask if the word "bouncer" can be translated with "Matón"? I find that a bit weird, but maybe it's correct. If it's not, please supply a proper translation, if possible.

comment:4 by m-kiewitz, 4 years ago

Owner: set to m-kiewitz
Resolution: fixed

comment:5 by SF/eliaorru, 4 years ago

The best word to translate bouncer is "guardia de seguridad", but it is a fairly generic term...more specific and also a little more informal are terms such as: "cadenero",or "gorila", or "patovica".
Thanks a lot for your work!
(Matòn is henchman or minion or contract killer )

comment:6 by SF/gsanmartin, 4 years ago

Sorry but if I might intervene I have never heard the words "cadenero" or "patovica", I think they might be Mexican? Not my intention to start a "Castillian vs Neutral Spanish" war, but I think those words would fit pretty badly with the rest of the translation, which was done in Spain.

I would need context (which scene is this?) but "Matón" might be a perfectly valid translation.

comment:7 by m-kiewitz, 4 years ago

Gabriel: I don't know what exactly happens in the game. Haven't played it yet.

Will close this bug for now.

comment:8 by m-kiewitz, 4 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.