Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6873 closed defect (fixed)

FARM: Crash at the end of trivia minigame on easy

Reported by: SF/somerandomhefan Owned by: Kirben
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

After answering all the trivia game's questions of the easy difficulty correctly, I get a congratulations message followed by the debug window giving me the error message "(69:41:0x17): o72_getResourceSize: default type 67!" If I close the debug window, the whole game is closed immediately. I haven't tested if the same happens on the other difficulties as well or also if not all questions are answered correctly.

Ticket imported from: bugs/6873.

Change History (11)

comment:1 by SF/somerandomhefan, 5 years ago

Ah, sorry. In case it wasn't clear, I'm talking about the game Let's Explore the Farm. It doesn't have its own milestone, so I had to put it here.

Also, I'm using the version available on Steam in case there are multiple versions.

comment:2 by Kirben, 5 years ago

I'm unable to reproduce the issue with the Windows version I own, so the problem might be limited to one specific version.

Could you please start ScummVM via a Command Prompt with debug level 1, and report the MD5 checksum listed. i.e. scummvm -d1 farm-win

comment:3 by SF/somerandomhefan, 5 years ago

I'll just give you the entire debug output in case some of the rest of it is important as well:

Using SDL Video Driver "windib" Using SDL Audio Driver "dsound" Output sample rate: 44100 Hz Output buffer size: 4096 samples User picked target 'farm-win' (gameid 'farm')... Looking for a plugin supporting this gameid... SCUMM [all games] Starting 'Let's Explore the Farm with Buzzy' SCUMM detector found matching file 'farm.he0' with MD5 a5c5388da9bf0e6662fdca881 3a79d13, size 86962

Using gameid farm, variant , extra SCUMM version 6, HE version 73 Using MD5 'a5c5388da9bf0e6662fdca8813a79d13' vars[225] = 0 (via script-0) vars[225] = 1 (via script-0) vars[226] = 0 (via script-0) vars[226] = 2 (via script-0) vars[227] = 0 (via script-0) vars[227] = 3 (via script-0) vars[228] = 0 (via script-0) vars[228] = 4 (via script-0) vars[229] = 0 (via script-0) vars[229] = 5 (via script-0) vars[230] = 0 (via script-0) vars[230] = 6 (via script-0) vars[231] = 0 (via script-0) vars[231] = 7 (via script-0) vars[232] = 0 (via script-0) vars[232] = 8 (via script-0) vars[233] = 0 (via script-0) vars[233] = 9 (via script-0) vars[234] = 0 (via script-0) vars[234] = 10 (via script-0) vars[235] = 0 (via script-0) vars[235] = 11 (via script-0) vars[236] = 0 (via script-0) vars[236] = 12 (via script-0) o72_readINI: Option HE9File Trying to open file 'farm.he9' WARNING: FSNode::createReadStream: 'Saved games\' is a directory! o72_openFile: slot 1, mode 1 DEBUG: machine-speed = FAST-MACHINE o72_readINI: Option TextOn DEBUG: number of sound channels is 8 o72_readINI: Option NoBackGroundSound o72_readINI: Option ReadPagesAutomatically o72_readINI: Option NoPrinting o72_readINI: Option FindItCheatKeyEnabled

comment:4 by Kirben, 5 years ago

The problem should be fixed in ScummVM GiT, try the next daily snapshot of ScummVM GiT.

comment:5 by SF/somerandomhefan, 5 years ago

The latest release is completely nonfunctional for me. I get an error message about 0xc000007b.

comment:6 by SF/somerandomhefan, 5 years ago

Okay, figured out what was wrong. For some reason, the new executable doesn't work when I put in the directory of the previous version. I'll test if the bug has been fixed.

comment:7 by SF/somerandomhefan, 5 years ago

It works. I'm getting the ending animation. Thanks for the help.

Perhaps you should make a separate milestone for this game though.

comment:8 by Kirben, 5 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:9 by SF/jumpyluff, 5 years ago

I'm experiencing this issue. What are all the steps I need to do in order to not get this error? I'm not exactly computer-techy, but I did try the command prompt thing and it didn't work out for me. What is the daily snapshot? I'm just entirely lost. Is there something extra I need to download? If so, where do I put it?

comment:10 by bluegr, 5 years ago

Hello

This issue has been fixed in the daily versions of ScummVM. Daily versions are constantly getting updated, but things might break because of the constant changes, which is why they are labelled as daily/unstable. When people have played the new games, or have tested changes to the old ones, then a new stable version is released (like 1.7.0).

You can find the daily versions of ScummVM in our downloads page, right under the stable versions: http://www.scummvm.org/downloads/#daily

comment:11 by SF/jumpyluff, 5 years ago

Do you have an estimate for when a new stable version will be released? And if it is released, will Steam games that use the 1.7.0 engine be updated?

Note: See TracTickets for help on using tickets.