Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6776 closed defect (fixed)

ZVISION: Nothing happens when I click on the rope in the bell room

Reported by: SF/natedavis82 Owned by: bluegr
Priority: normal Component: Engine: ZVision
Keywords: Cc:
Game: Zork Nemesis

Description

Stuck in the bell room. The rope is released by pressing the proper symbols in order on the instrument and then when I click on the rope I only hear the sound effects of me climbing it, but the screen just freezes. I can move the cursor, but I can't back out to try again. I have tried restoring to a previous game point and closing and re-opening Scummvm, but the problem remains. I am using build mingw-w64-master-9f00880a.

Ticket imported from: bugs/6776.

Attachments (2)

nemesis.PNG (138.4 KB ) - added by SF/natedavis82 5 years ago.
znemesis.002 (11.8 KB ) - added by SF/natedavis82 5 years ago.

Download all attachments as: .zip

Change History (9)

by SF/natedavis82, 5 years ago

Attachment: nemesis.PNG added

comment:1 by digitall, 5 years ago

Summary: Nothing happens when I click on the rope in the bell roomZVISION: Nothing happens when I click on the rope in the bell room

comment:2 by RichieSams, 5 years ago

Can you attach a savegame?

by SF/natedavis82, 5 years ago

Attachment: znemesis.002 added

comment:3 by SF/natedavis82, 5 years ago

Of course. Should have thought of that.

comment:4 by bluegr, 5 years ago

This is odd

This is a "hotmov" control, used only by Nemesis in 2 screens (this one, plus the very last screen).

I've tried this with 3 setups:
- Windows 7, latest ScummVM built with MSVC ---> works
- Windows 7, latest buildbot build ---> does not work
- Ubuntu, latest ScummVM built with g++ ---> does not work

So, this works with MSVC, but not with g++... Seems like we're doing something that g++ doesn't like. Perhaps there are differences in a way some strings are handled via sscanf()?

This scene uses the following files:
- mj7g.scr - location script
- mj7eb11c.tga - the location image (wall + rope)
- mj7eq1tc.raw - the bell sound
- roperide.hsm - the file containing all the movie frames, plus the hotspot for each frame
- mj7ea11c.avi - the rope climbing animation (which contains the hotspots)
- mj7ea21c.avi - the movie that gets played when the user clicks on the hotspot correctly

I don't get any warnings in the console, so all of the files seem to be loaded correctly.

It seems that the rope climbing video file (mj7ea11c.avi) is not played, for some reason in g++

comment:5 by wjp, 5 years ago

For what it's worth, it's working properly for me with gcc 4.7.3, x86_64, linux.

comment:6 by bluegr, 5 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:7 by bluegr, 5 years ago

OK, figured out what happened here.

In the Zork: Nemesis version bundled in the ZGI SE DVD, the bell rope
puzzle has been modified so that it's non-interactive, i.e. there isn't
a hotspot to click while the video is playing, and the player is
transported to the next room. In the patched script, all criteria of
that puzzle were commented out, resulting in an invalid puzzle criteria list.

This has been fixed with commit 750d72812b. The fix will be available
in the next daily version of ScummVM.

Closing as fixed.

Note: See TracTickets for help on using tickets.