Opened 5 years ago

Closed 5 years ago

Last modified 9 months ago

#6741 closed defect (fixed)

ANDROID: AssetFdStream deletes ref too early

Reported by: SF/manul12 Owned by: SF/mthreepwood
Priority: normal Component: Port: Android
Keywords: Cc:
Game:

Description

ScummVM version: 1.7.0 for Android
Platform: Android

Bug details: When starting ScummVM on Nexus 7 (2013) on a Android 5.0 "Lollipop" Preview, it first displays a progress bar then exits to homescreen. After that it just always exits to homescreen.

I'm not an Android programmer, but on #ScummVM on IRC I was told to use USB debugging and adb logcat, and it produced the logs you can read in attachment.

Ticket imported from: bugs/6741.

Attachments (1)

logcat.txt (42.7 KB) - added by SF/manul12 5 years ago.

Download all attachments as: .zip

Change History (12)

Changed 5 years ago by SF/manul12

Attachment: logcat.txt added

comment:1 Changed 5 years ago by fuzzie

Looks like a really stupid mistake by me (the local ref is getting deleted too early). We should merge pull request #433 which replaces all this code.

comment:2 Changed 5 years ago by fuzzie

Owner: set to fuzzie
Summary: Android 5.0 Preview - Nexus 7 2013 - crashes to homescreenANDROID: AssetFdStream deletes ref too early

comment:3 Changed 5 years ago by digitall

fuzzie: Is there an "simple" fix for now, or would this need a major fixup?

comment:4 Changed 5 years ago by bluegr

I don't think that there's any point in making an "easy" fix for this, since the relevant code will be replaced altogether

comment:5 Changed 5 years ago by SF/mthreepwood

Owner: changed from fuzzie to SF/mthreepwood
Resolution: fixed

comment:6 Changed 5 years ago by SF/mthreepwood

This should now be fixed in b577da2. I don't have a 5.0 device to test, but it was a pretty obvious bug in the code. Let me know with the new daily build (after that commit) if it's still not working for you.

comment:7 Changed 5 years ago by SF/mthreepwood

Status: newclosed

comment:8 Changed 5 years ago by SF/mthreepwood

Those on the forum who have tested it confirmed the bug is fixed. Closing.

comment:9 Changed 4 years ago by SF/tsoikkeli

Good evening. Sorry for the inconvinience but when you would expect this land to Google Play?

comment:10 Changed 4 years ago by SF/haridan

I'm still seeing this crash on the version currently available on Google Play on my Nexus 6.

comment:11 Changed 9 months ago by digitall

Component: Port: Android
Note: See TracTickets for help on using tickets.