Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#6737 closed defect (fixed)

AGI: Voodoo Girl (Fan) - Scene gets repeatedly reloaded

Reported by: raziel- Owned by: m-kiewitz
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: AGI Fanmade

Description

ScummVM 1.8.0git (Sep 22 2014 10:10:52)
Features compiled in: TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG

There is a scene in the game where one has (fortunately) just pass through.
It's a view of a waterfall where ego has to pass behind to get along.

This scene features a waterfall with different states (actually it seems to be at least two screens looking exactly the same, except for the waterfall) to fake movement.

ScummVM is unfortunately loading the whole scene over and over again, which results in the passing being a pita, taking hillariously long and the waterfall looks like a dia show.

I don't know how that is supposed to look like in the original interpreter.

The game is freely available here:
http://www.agidev.com/dl_files/games/vgsrc.zip

Voodoo Girl - Queen of the Darned (v1.2 2002 Jan 1) (DOS/English)

From the savegame, go right

AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: bugs/6737.

Attachments (1)

agi-fanmade-1.009 (2.8 KB) - added by raziel- 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by raziel-

Attachment: agi-fanmade-1.009 added

comment:1 Changed 4 years ago by m-kiewitz

Owner: set to m-kiewitz

comment:2 Changed 4 years ago by m-kiewitz

this bug seems to be solved in my current work-in-progress graphics rewrite.
Marking for later.

comment:3 Changed 4 years ago by m-kiewitz

Resolution: fixed
Status: newclosed

comment:4 Changed 4 years ago by m-kiewitz

This is now fixed by commit 8a595e7771aa89d06876e13d7ab6751e26da8982

It was caused by us delaying all room changes and background picture changes and we did that because quite a few games show a message box right before changing rooms and not doing any delay at all. The original creators expected the room loading to take a few seconds, which isn't the case now anymore of course. I changed that code, so that it detects such situations and delays only in those cases, which is why this issue is now solved.

Note: See TracTickets for help on using tickets.