Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6657 closed defect (fixed)

INDY3: Wrong sound when opening/closing doors (AdLib regression)

Reported by: eriktorbjorn Owned by: lordhoto
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

This happens with the latest Git snapshot of ScummVM, English VGA version of the game.

When opening/closing doors at the university, either by yourself or if an NPC does it, the AdLib sound effect is wrong. Here are two recordings to illustrate it. (The footsteps in them belong to Marcus.) ScummVM is using the DOSBox OPL emulator, not the MAME one

ScummVM: http://www.update.uu.se/~d91tan/ScummVM/indy3-scummvm.ogg
DOSBox: http://www.update.uu.se/~d91tan/ScummVM/indy3-dosbox.ogg

Ticket imported from: bugs/6657.

Change History (3)

comment:1 Changed 5 years ago by lordhoto

Owner: set to lordhoto
Resolution: fixed
Status: newclosed

comment:2 Changed 5 years ago by lordhoto

Should be fixed with 0fb812fe3b0a6043d1856d37697ee50e7342cb6d. The actual sound is still dependant on the output rate used. When I use 44kHz in both ScummVM and DOSBox it sounds the same to me. However, when you start to use a different rate it will sound differently.

comment:3 Changed 5 years ago by eriktorbjorn

Actually, I just tried yesterday's version with 44 kHz and that sounded fine too. I usually run at 44 kHz, but for release testing I try to use the default settings instead.

Perhaps the time has come to make 44 kHz the default, at least in the desktop version?

Note: See TracTickets for help on using tickets.