Opened 17 years ago

Closed 17 years ago

Last modified 11 months ago

#664 closed defect (wontfix)

build on FreeBSD is not working out of the box

Reported by: SF/boelthorn Owned by:
Priority: normal Component: Port: BSD
Keywords: Cc:
Game:

Description

There should be an option to the configure script where
and under what name to find the sdl-config script.

As it is hard-coded to 'sdl-config' without any error
checking the build results in _many_ warnings and error
messages, before gcc finally gives up to compile on my
system where sdl-config is actually named sdl11-config:

~/src/scummvm/backends/sdl> sdl11-config --version
1.2.5

If I manually substitute all 'sdl-config' with
'sdl11-config' the build and ScummVM itselfs works
flawless.

Ticket imported from: #664719. Ticket imported from: bugs/664.

Change History (4)

comment:1 by fingolfin, 17 years ago

Just edit build.rules. I have to do that on OS X, too, after all.

Furthermore, I consider it a severe bug in FreeBSD that they *still* incorrectly renamed sdl-config to sdl11-config - SDL is not even at version 1.1 anymore, and 1.1. never was intended for a broad audience anyway, it was the development branch of SDL between 1.0 and 1.2

comment:2 by fingolfin, 17 years ago

Owner: set to fingolfin
Resolution: wontfix
Status: newclosed

comment:3 by Strangerke, 6 years ago

Component: --Unset--Ports
Owner: fingolfin removed

comment:4 by digitall, 11 months ago

Component: PortsPort: BSD
Note: See TracTickets for help on using tickets.