Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6636 closed defect (fixed)

RINGWORLD2: Drawing glitch (transparency?) in flup tube system

Reported by: eriktorbjorn Owned by: dreammaster
Priority: normal Component: Engine: TsAGE
Keywords: Cc:
Game: Return to Ringworld

Description

When in the flup tubes, it looks like the ship may be drawn without transparency, or something like that. It's most noticeable at the starting point of the maze.

Ticket imported from: bugs/6636.

Attachments (2)

ringworld2-cd.041 (8.3 KB) - added by eriktorbjorn 5 years ago.
FlupTube.png (6.0 KB) - added by eriktorbjorn 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by eriktorbjorn

Attachment: ringworld2-cd.041 added

Changed 5 years ago by eriktorbjorn

Attachment: FlupTube.png added

comment:1 Changed 5 years ago by eriktorbjorn

Here is an image showing a detail from both a DOSBox and a ScummVM screenshot.

comment:2 Changed 5 years ago by eriktorbjorn

By the way, using that savegame shows another glitch: The maze isn't fully redrawn when the savegame is loaded. But I guess that should be its own bug report at some point...

comment:3 Changed 5 years ago by eriktorbjorn

Component: Engine: TsAGE
Game: Return to Ringworld

comment:4 Changed 5 years ago by dreammaster

Owner: set to dreammaster
Resolution: fixed
Status: newclosed

comment:5 Changed 5 years ago by eriktorbjorn

I flew around for a while, and I couldn't reproduce the deadlock. Encouraging, but not conclusive since it doesn't happen that often to begin with, but I don't have the time to test more at the moment.

The other hang, where the mouse cursor goes away but the sound is still playing, still happened once. I haven't been able to figure out a way to reproduce that, but when it happens it always seems to be when I'm trying to navigate a tight corner, so I'm pressing the arrow keys rapidly. Perhaps there's a clue there.

Overall, input handling in that maze seems a bit odd. Sometimes I can right-click to bring up the verbs menu (though I don't know what good that would do me), other times I'm told (correctly?) that it wouldn't benefit me.

comment:6 Changed 5 years ago by eriktorbjorn

[Deleted. I posted this comment to the wrong bug report.]

comment:7 Changed 5 years ago by eriktorbjorn

Resolution: fixed
Status: closednew

comment:8 Changed 5 years ago by eriktorbjorn

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.