Opened 6 years ago

Closed 6 years ago

#6503 closed defect (fixed)

RINGWORLD2: Scanner oddities

Reported by: eriktorbjorn Owned by: Strangerke
Priority: normal Component: Engine: TsAGE
Keywords: Cc:
Game: Return to Ringworld

Description

English CD version of the game.

When arriving at Ringworld, there are two things about Quinn's scanner that strike me as odd. (Perhaps I should have filed separate bug reports about them.) I have not compared either of them to DOSBox.

  • There are voice-overs for at least some of the scanner results, but often much shorter than the text presented on screen. And the voice-overs go away if I disable subtitles. That seems counter-intuitive.

  • A short passive geographical scan reveals a solar body within 100 AU. Shouldn't that be the astronomical scan instead? A short active astronomical scan reveals more facts about the star.

Ticket imported from: bugs/6503.

Attachments (1)

ringworld2-cd.010 (18.8 KB ) - added by eriktorbjorn 6 years ago.

Download all attachments as: .zip

Change History (13)

by eriktorbjorn, 6 years ago

Attachment: ringworld2-cd.010 added

comment:1 by eriktorbjorn, 6 years ago

Component: Engine: TsAGE
Game: Return to Ringworld

comment:2 by eriktorbjorn, 6 years ago

The short scanner actually matches the original behaviour, i.e. it's the passive geographical scan that reveals a solar body, while an active astronomical scan reveals details about it. It still feels like a bug to me.

comment:3 by eriktorbjorn, 6 years ago

The voice-overs, on the other hand, are cut short in ScummVM. It's apparently supposed to read the whole thing that's on screen, without interruptions.

comment:4 by Strangerke, 6 years ago

Original game issue fixed in 4539eee05f34cf3131926fa21a31a8f8ec50af5f.
I wasn't able to reproduce the voice-overs issue, could you give me details?

comment:5 by eriktorbjorn, 6 years ago

For instance, if I do a deep, active astronomical scan, I get the following text:

MESSAGE:
Within 5 UNS light years
G class star within 100 AU - 01 Mark 12 - 1.96 x 10^8 UNS miles
Massive ring-shaped artifact - 01 Mark 12 - 9.1 to 37.0 x 10^7 UNS miles

In ScummVM, the voice-over only reads the first line, "Within 5 UN standard light years". In DOSBox, the voice-over reads all of the text. In both cases, I've enabled both speech and subtitles.

comment:6 by dreammaster, 6 years ago

I think I've resolved the problem. The PlayStream::dispatch method was never being called, so the PlayStream was never able to detect that it was finished, and call the end action, which in this case causes the scene to start playing the next line.

I've done some preliminary tests, and it all looks good, but I'll leave it to Strangerke to confirm and close this bug.

comment:7 by dreammaster, 6 years ago

Owner: set to Strangerke

comment:8 by Strangerke, 6 years ago

Resolution: fixed

comment:9 by Strangerke, 6 years ago

Fixed imho, waiting for eriktorbjorn approval to close the issue

comment:10 by eriktorbjorn, 6 years ago

An active, deep technological scan behaves oddly for me. It repeats "Dimensions: Radius: 0.99 astronomical units" several times, and never gets to the lines after that. (If you can't reproduce that, I'll try a clean build later.)

comment:11 by eriktorbjorn, 6 years ago

Dreammaster seems to have fixed it now.

comment:12 by eriktorbjorn, 6 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.