Opened 6 years ago

Closed 6 years ago

#6462 closed defect (fixed)

SCI: LB2 - Room-specific music and generic music playing at once

Reported by: SF/boneosaurusrex Owned by: wjp
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Laura Bow 2: The Dagger of Amon-Ra

Description

When in a museum room with its own music (Yvette's, Carrington's, Egypt wing, etc) the generic museum background track continues to play at the same time as the room music, instead of only playing the room music which is what's supposed to happen as in the original. This also occurs in insets with their own music, such as when examining a body. Both floppy and CD versions are affected.

This appears to be a regression of bug #5204 which was marked as fixed but describes the exact behavior I'm seeing in 1.6 and 1.7 latest (Win32). I have the 1.5 iPhone build and it is playing the music correctly for the most part.

Attached is a savegame of the CD version outside Yvette's and Olympia's offices. The egypt wing is also good for testing because its music is so light.

Ticket imported from: bugs/6462.

Attachments (1)

laurabow2-cd.028 (50.6 KB ) - added by SF/boneosaurusrex 6 years ago.

Download all attachments as: .zip

Change History (6)

by SF/boneosaurusrex, 6 years ago

Attachment: laurabow2-cd.028 added

comment:1 by wjp, 6 years ago

I had to remove the fixes for bug #5204 as they were breaking fades in other games. Further improvements to this code are in my SCI midi remapper branch, but it's still not quite fixed there.

When entering Yvette's, the main music (gameMusic1) is properly faded out, but after the fade it's immediately restarted at full volume by the scripts by gameMusic1::check / WrapMusic::cue.

When testing, note that the attached savegame already has two songs playing.

comment:2 by wjp, 6 years ago

I went through some of the remaining CHECKMEs in the fading code, and compared with WrapMusic::cue. It looks like this could be caused by us setting signal to 0xFF after fading, instead of to 0xFE. We need to figure out which games need which signal. (See the comments in SoundCommandParser::processUpdateCues)

comment:3 by wjp, 6 years ago

This should now be fixed by commit 35617bf6. A related issue is that the fades when changing rooms are still a bit more sudden than they should be, but that is already fixed on my remapping branch.

Thanks for the report.

comment:4 by m-kiewitz, 6 years ago

Component: Engine: SCI
Game: Laura Bow 2: The Dagger of Amon-Ra

comment:5 by wjp, 6 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.