Opened 6 years ago

Closed 6 years ago

#6300 closed defect (fixed)

HOPKINS: GMM save/load issue

Reported by: misterhands Owned by:
Priority: normal Component: Engine: Hopkins
Keywords: Cc:
Game: Hopkins FBI

Description

Latest Win64 daily
Hopkins Win FR

It looks like when we are in the main game menu, the GMM save/load is does nothing and sometimes it is disabled (grayed).
I'm not sure if it's supposed to be grayed at all times, or to be functional, but either way the current behavior looks incorrect.

Ticket imported from: #3612112. Ticket imported from: bugs/6300.

Attachments (1)

hopkins-win-fr.004 (7.4 KB ) - added by misterhands 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 by Strangerke, 6 years ago

The save/load is not always allowed in the game, and we enforced the same check on GMM level. Therefore, you can't save/load during animations and in the city map. Could you tell us if the issues you encountered are in those parts of the game, or if the problem occurred more randomly?

comment:2 by misterhands, 6 years ago

No, the in-game GMM save/load works fine, the problem is when you are in the main game menu (the one that allows you to watch the introduction).

comment:3 by misterhands, 6 years ago

In addition to the problem mentioned in the bug report, I've found a place where you can use GMM save/load when the in-game save/load is disabled: the sub sequence. If you save at that time, loading that save puts you back at the previous room. The inventory then seems to be disabled.
See the attached save that demonstrates this.

by misterhands, 6 years ago

Attachment: hopkins-win-fr.004 added

comment:4 by dreammaster, 6 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.