Opened 6 years ago

Closed 6 years ago

#6280 closed defect (fixed)

AGI: issetv-command returns only false value

Reported by: SF/sterv Owned by: wjp
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: AGI Fanmade

Description

ScummVM-version: 1.5.0
Platform: Linux 64 bit ( Ubuntu 12.04 .deb )
Bug: AGI-command issetv(var vA) returns only false value
How to reproduce:

reset(f195); // Resetting flag 195
v40 = 195; // Setting variable 40's value to 195
toggle.v(v40); // Toggling flag 195 from reset to set
if (issetv(v40)) {print("%v40 TRUE");}
if (!issetv(v40)) {print("%v40 FALSE");}

Ticket imported from: #3611262. Ticket imported from: bugs/6280.

Change History (8)

comment:1 Changed 6 years ago by SF/sterv

Summary: issetv-command returns only false valueAGI: issetv-command returns only false value

comment:2 Changed 6 years ago by wjp

Which AGI version are you emulating in ScummVM?

comment:3 Changed 6 years ago by SF/sterv

v2.917

comment:4 Changed 6 years ago by wjp

Looks like we had a typo in that test. I fixed that in commit e4a9717434190fdd4. Could you verify if it works in the next daily build of ScummVM?

comment:5 Changed 6 years ago by wjp

Owner: set to wjp
Resolution: fixed
Status: newpending

comment:6 Changed 6 years ago by SF/sterv

I will do that once it's available just in case since I already tested by downloading 1.5.0-source, manually adding your fix, compiled and it works. Thank you for the quick fix.

comment:7 Changed 6 years ago by SF/sterv

Status: pendingnew

comment:8 Changed 6 years ago by wjp

Status: newclosed
Note: See TracTickets for help on using tickets.