Opened 18 years ago

Closed 16 years ago

#628 closed defect (fixed)

DOTT: Speech bug

Reported by: SF/bigjko Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Day of the Tentacle

Description

I've noticed that in the future when Purple Tentacle is talking to a young green tentacle, where he's supposed to interrupt the young tentacle, the green tentacle's mouth keeps moving(without any speech going on) before Purple Tentacle can actually interrupt him. Then after a small while he tries to utter a word with Purple Tentacle interrupting, as it's supposed to be.

Thought I'd report this. Attached is a savegame in the "Meanwhile.." scene. Just load that and the bug is reproduced.

Ticket imported from: #653297. Ticket imported from: bugs/628.

Change History (14)

comment:1 by SF/bigjko, 18 years ago

Ooops, forgot all the neccessary version infos.

ScummVM version 0.3.1 CVS 13.dec

English Talkie version of DOTT

Win32 enviroment, GCC compiler.

comment:2 by SF/jamieson630, 18 years ago

Summary: Speech bug.DOTT: Speech bug.

comment:3 by fingolfin, 18 years ago

Related to bug #655443 ?

comment:4 by fingolfin, 18 years ago

Sorry, I meant bug #656025

comment:5 by fingolfin, 18 years ago

Summary: DOTT: Speech bug.DOTT: Speech bug

comment:6 by SF/wishbone, 18 years ago

I've seen this as well. As far as I can tell, what happens is that the speech is faster than the subtitles, but for timing purposes (the mentioned interruption by Purple Tentacle), the speech is separated into two parts. It seems to me that the script starts the first part of the speech, and the subtitles that go with it, simultaneously. It then waits until both are finished, but because the speech is over too quickly, the green tentacle ends up miming to the subtitles for a while, before the next part of the speech (with the interruption) begins. It also appears that the animation of the green tentacle is keyed to the subtitles, not the speech. I think this is likely, as otherwise, the script would have had to be rewritten for the talkie version.

Anyway, I just thought I'd put my two cents in.

Wishbone

comment:7 by fingolfin, 17 years ago

What's the status of this? Does it still occur? If yes, does somebody have a save game just before the issue?

comment:8 by SF/noscript, 17 years ago

Same problem with German Version

Here are some Savegames: http://www.the- nemesis.net/tentacle.zip

Epilogue when bernhard speaks. Turn on Subtitles

comment:9 by eriktorbjorn, 17 years ago

I played this scene once in DosBox some time ago, for comparision. My impression was that the original lip-syncs with the sound, i.e. when the sound stops the mouth stops moving, while ScummVM lip-syncs with the subtitles, i.e. when the subtitles are removed the mouth stops moving.

But I could very well be mistaken about that.

comment:10 by Kirben, 16 years ago

The timing is based on speech, if subtitles are disabled now.

Could someone please attach a saved game, that link no longer works.

comment:11 by eriktorbjorn, 16 years ago

The savegame attached to http://sourceforge.net/tracker/index.php?func=detail&aid=884171&group_id=37116&atid=418820 should work. (And if you manage to find the fix for that glitch while you're at it... so much the better! ;-)

comment:12 by Kirben, 16 years ago

Owner: set to Kirben

comment:13 by Kirben, 16 years ago

Resolution: fixed
Status: newclosed

comment:14 by Kirben, 16 years ago

The poor timing of the subtitles is a limitation of the original game. I fixed the problem of mouth moving after speech finished though.

Note: See TracTickets for help on using tickets.