Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6268 closed defect (fixed)

SCI: KQ6: Crash After Taking Parchment from Black Window Web

Reported by: SF/codahq Owned by: wjp
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 6

Description

This was originally reported here:
3555404
It was probably also reported in other bugs as well. The code looks to have either been undone by a recent commit or never merged because the issue still exists in the latest version of ScummVM downloaded today. The single workaround cited in the original bug report does not work.

Game play cannot progress past this point.

Ticket imported from: #3610063. Ticket imported from: bugs/6268.

Change History (3)

comment:1 by wjp, 7 years ago

Summary: Crash After Taking Parchment from Black Window WebSCI: KQ6: Crash After Taking Parchment from Black Window Web

comment:2 by wjp, 7 years ago

I think I've found the root cause of this now and have reverted the fixes to the previous times this bug showed up (bug reports #3291115, #3555404, #3596335). It should be fixed by commit 18feefbe40.

Thanks for reporting this.

comment:3 by wjp, 7 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.