Opened 18 years ago

Closed 18 years ago

#626 closed defect (fixed)

SAM: No Music In Hallway

Reported by: SF/unno Owned by: SF/jamieson630
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

In version 0.3.0b, when you walk from the street into your office building, there is no music in the hall. The street music just fades out to scilence. This occured on both the adlib and windows music settings. It seems to be very repeatable. Just leave the building and re-enter it. There's no music. I've check the original game, and the bug isn't present there.

I'm running the English version of the CD-talkie game in Win 98. You won't really need a saved game. Just skip all the dialog and cut-scenes at the beginning, leave the building, and re-enter it.

Unno

Ticket imported from: #651727. Ticket imported from: bugs/626.

Change History (5)

comment:1 by SF/jamieson630, 18 years ago

Thanks, this is the first time anybody has confirmed that the original EXE actually still had hallway music when returning from the outside. Thus, I will add this to my list of things yet to fix in Sam & Max.

comment:2 by SF/jamieson630, 18 years ago

Owner: set to SF/jamieson630

comment:3 by fingolfin, 18 years ago

Summary: No Music In HallwaySAM: No Music In Hallway

comment:4 by SF/jamieson630, 18 years ago

Resolution: fixed
Status: newclosed

comment:5 by SF/jamieson630, 18 years ago

Fixed, at least partially. This is the first time I've seen something use do_command(20) : Deferred Command. Since we don't have much information on this command, I've implemented something that at least works for this particular problem. One of the parameters may still be significant, though, and is presently ignored. I've included warning output so we can find where else this command may be cropping up.

Note: See TracTickets for help on using tickets.