Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#6237 closed defect (fixed)

AGI (fan) SQ0: Ego erased too soon on scene switch

Reported by: raziel- Owned by: m-kiewitz
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: AGI Fanmade

Description

ScummVM 1.6.0git (Jan 23 2013 23:58:45)
Features compiled in: Vorbis FLAC MP3 RGB zLib Theora AAC FreeType2

Ego is erased far too early on every scene switch.
Just walk out the scene, ego will be erased a good second before the scene switches to black and eventuially to the new scene where ego also takes quite some time to be drawn again (but not that long as when the scene is left)

Another problem is that sometimes when text windows come up ego is erased and drawned again which leads to partially erased inventory items when ego is standing at the position the picture of the iem will be drawn.

Space Quest 0: Replicated (v1.04/DOS/English)

AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #3602095. Ticket imported from: bugs/6237.

Change History (6)

comment:1 Changed 6 years ago by raziel-

It's getting worse.
Now ego gets erased every time a text message window is popping up while ego is partially covered by the window.

Best reproduced when looking at inventory items with F4.

comment:2 Changed 6 years ago by raziel-

Commit ffc390e64c1adc8bd863ecd0bfe72ff7ecba6832 is the one that breaks both behaviours

comment:3 Changed 4 years ago by m-kiewitz

Owner: set to m-kiewitz

comment:4 Changed 4 years ago by m-kiewitz

this bug seems to be solved in my current work-in-progress graphics rewrite.
Marking for later.

comment:5 Changed 4 years ago by m-kiewitz

Resolution: fixed
Status: newclosed

comment:6 Changed 4 years ago by m-kiewitz

This is now fixed by commit 8a595e7771aa89d06876e13d7ab6751e26da8982

Note: See TracTickets for help on using tickets.