Opened 7 years ago

Closed 6 years ago

#6198 closed defect (fixed)

WME: Chivalry - some sound problems

Reported by: misterhands Owned by: somaen
Priority: normal Component: Engine: Wintermute
Keywords: Cc:
Game: Wintermute

Description

Latest Win64 nightly
Chivalry is not dead from this page:
http://www.deirdrakiai.com/my-games/#chivalry

1) The footsteps sounds are not right. Many are missed as you walk the character around, and also it sounds different than the original, more like a bigger knocking sound rather than a normal walking sound.

2) there is a frequent POP noise that sounds like it occurs when looping the cricket sound, when standing in front of the guard.

Ticket imported from: #3592165. Ticket imported from: bugs/6198.

Change History (14)

comment:1 by digitall, 7 years ago

Owner: set to somaen

comment:2 by somaen, 7 years ago

Should be fixed now. Could you please verify?

comment:3 by somaen, 7 years ago

Please test whether you can reproduce this bug
with the latest daily SVN build which you can find
at the bottom of our downloads page:
<http://www.scummvm.org/downloads.php>.

comment:4 by somaen, 7 years ago

Status: newpending

comment:5 by somaen, 7 years ago

Resolution: fixed

comment:6 by misterhands, 7 years ago

The popping is fixed. My ears are grateful ! :-)

The footsteps seem to be a bit better, but still off compared to the original.
In the original there is one step sound per step, whereas in ScummVM, the footsteps sounds seem to be a bit lagging and irregular : they go toc-toc--------toc-----toc-toc------toc etc instead of being even.

comment:7 by digitall, 7 years ago

Resolution: fixed
Status: pendingnew

comment:8 by misterhands, 6 years ago

There is the same lagging problem with the footsteps sounds in Dirty Split.

comment:9 by somaen, 6 years ago

As far as I can test, they seem to be correct, and even, the only step that was missed was if I changed direction at the correct moment. To be sure, I used ctrl-f5->options to reduced the music (chirps), and increase the sfx-volume.

I did get one double-step, but presumably this stemmed from a step cut short as the actor reached his destination.

comment:10 by misterhands, 6 years ago

Just tried again with a recent build and I still get some missed footsteps sounds.
The way the footsteps sounds come out (or not) seems quite random too.

Personally, I get double-steps about 50% of the time, walking in a straight line (in Chivalry and Dirty Split). No such issue with the original executables.

And as I mentioned, the footsteps sounds are lagging/late for me.
You don't get a nice and clean 1 sound per step at the right time (when the foot hits the ground) like in the original (Chivalry and Dirty Split).

In fact, I've found that for me, every sound in ScummVM's WME is delayed by roughly 500ms.

But - after some testing I've just found out that I have the same exact issue in other engines, like in Full Throttle or Bargon Attack. Only in ScummVM, the originals are fine. So either it's my system, or there is a common audio problem.

Found this, maybe it's related:

5837 SDL mixer output buffer size warning

https://sourceforge.net/p/scummvm/bugs/5837/

The warning I get is:
WARNING: SDL mixer output buffer size: 11028 differs from desired: 4096!

So according to LordHoto's comment on that bug, that may explain the lag.

comment:11 by somaen, 6 years ago

Would you happen to have any other computer/OS to test this on? It's looking like it's not an issue with WME from what you tell me.

comment:12 by misterhands, 6 years ago

Yes it's clear now that it's not a WME issue.
Did some testing with my laptop, also win7 64 based => same problem.
Tested with a Win32 nightly of ScummVM, idem.

But, I've found that the sound lag - and the SDL buffer warning - are not present in 1.6.
I couldn't test WME of course, but FT and BA are free of sound lags.
So it seems to be an issue with the nightly builds, at least the Win 32 and Win 64 ones.

comment:13 by misterhands, 6 years ago

As the WME sound issue is fixed, this can be closed.
I have posted a new bug report about the SDL audio lag:

https://sourceforge.net/p/scummvm/bugs/6510/

comment:14 by somaen, 6 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.