Opened 7 years ago

Closed 6 years ago

#6181 closed defect (fixed)

SCI: QFG1VGA - game hangs in the warlock's maze

Reported by: misterhands Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: Quest for Glory 1

Description

Latest Win64 build
QFG1VGA

In the warlock's maze, pushing the button on the right after opening the door results in a funny script bug in which the Hero takes a ball on the head, falls, comes out of the back door rolling, is turned into an animated staircase, then the message "There's an ECHO IN HERE... Echo in Here... echo in here..." appears. The actual text can vary as they are several messages cycling.
After that he is turned to man again (phew), and walks out of the left back door.
The ending apparently depends from the delay before you skip that message box:
- In one case (fast skip), things look like they are back to normal but clicking or trying anything causes the Hero to be slowly dragged across the screen to the lower right corner, and finally freeze...
- In the other case (slow skip) the hero automatically start this drag move but stops very early and just freezes there.
In both cases the game is now frozen, you have to reload.

Probably Yorick's most evil trick ! :-)
It almost looks like an easter egg, except for the game freezing part...

To see what should (presumably) happen, wait a few seconds for the door to close, then push the button.
Less fun, but at least it does not crash.

It looks like what happens is the normal push_the_button routine is run, and then it switches to enter_the open_door, which should not happen and creates this mess.

This bug probably occurs also in DOSBox, although I can't try because you can't reach this point of the game quickly from the beginning, and the original debugger doesn't work even with the magic script #10 from LB2CD renamed to #298 trick.
This looks very much like a script bug anyway.

Ticket imported from: #3585793. Ticket imported from: bugs/6181.

Attachments (1)

qfg1vga.099 (36.1 KB) - added by misterhands 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by misterhands

Attachment: qfg1vga.099 added

comment:1 Changed 7 years ago by bluegr

This is a tough one to debug... the whole room is supposed to be whacky, especially that button (which is there for comic relief, AFAIK). It seems to be "fixed" by the QFG1 NRS patch, as it doesn't freeze, but it's still all wrong, but the patch itself is odd, so the whole situation needs more work to figure out the exact cause.

comment:2 Changed 6 years ago by m-kiewitz

I just checked in collaboration with wjp.
It also happens in SSCI. Confirmed using qfg1vga from the QfG Anthology.

comment:3 Changed 6 years ago by m-kiewitz

Keywords: original added; script removed

comment:4 Changed 6 years ago by m-kiewitz

Owner: set to m-kiewitz
Resolution: fixed

comment:5 Changed 6 years ago by m-kiewitz

fixed today by e4568817bb4a6f7631d8253d32d7b2fb3f2d72a2
added script patch to fix this buggy behaviour

comment:6 Changed 6 years ago by m-kiewitz

Status: newclosed
Note: See TracTickets for help on using tickets.