Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6071 closed defect (fixed)

COMPOSER: Imo & the King Crash at start

Reported by: SF/scoriae Owned by: fuzzie
Priority: normal Component: Engine: Composer
Keywords: Cc:
Game:

Description

Game version:
Magic Tales: Imo and the King (Windows/English)

ScummVM Version:
1.5.0git3295-g848575b (June 28 2012 11:09:59)

Crash:
On launch the Magic Tales logo appears for a second and the the program stops responding.

The console reports:
Assertion failed: isValidName(section), file common/config-file.cpp, line 289

Ticket imported from: #3539019. Ticket imported from: bugs/6071.

Attachments (3)

scummvm.ini (522 bytes) - added by SF/scoriae 7 years ago.
recreated scummvm.ini file w/ just the two crashing games
BOOK.INI (3.7 KB) - added by digitall 7 years ago.
The Little Samurai - book.ini
The Little Samurai.md5 (1.9 KB) - added by SF/scoriae 7 years ago.
md5 of The Little Samurai's contents.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 7 years ago by digitall

Component: Engine: MohawkEngine: Composer

comment:2 Changed 7 years ago by digitall

Owner: set to fuzzie
Summary: Imo & the King crash on launchCOMPOSER: Imo & the King Crash at start

comment:3 Changed 7 years ago by digitall

scoriae: That assertion failure is associated with corruption of the ScummVM configuration file.

Please backup and remove your current configuration file, which can be found at:
http://wiki.scummvm.org/index.php/User_Manual/Configuring_ScummVM#Using_the_configuration_file_to_configure_ScummVM
so that ScummVM can generate a fresh file, then re-detect this game.

If the crash still then occurs, please attach the new minimal file to this bug.

comment:4 Changed 7 years ago by digitall

It should be noted that scoriae reported the same issue with "Magic Tales: The Little Samurai (Windows/English)", so any fix should be tested with this as well. See bug #3539020:
https://sourceforge.net/tracker/index.php?func=detail&aid=3539020&group_id=37116&atid=418820

Changed 7 years ago by SF/scoriae

Attachment: scummvm.ini added

recreated scummvm.ini file w/ just the two crashing games

comment:5 Changed 7 years ago by SF/scoriae

Still crashes. New scummvm.ini file attached.

comment:6 Changed 7 years ago by digitall

scoriae: OK. Two questions:
1. I assume that you have tried running this from a console and you get the same assertion failure as previously reported.
2. I have reviewed your attached scummvm.ini. The issue may be related to the brackets in the game data paths.
Please can you try removing both entries again or starting with no file present, and rename both of your game data
directories to not have the "(CD Windows)" i.e. rather than Z:\ScummVM\Imo & The King (CD Windows)\, say
Z:\ScummVM\Imo & The King CD Windows\ and then re-add and try them.

comment:7 Changed 7 years ago by digitall

If this still fails to fix the issue, please can you attach the book.ini from one of these games to this bug as an attachment. If this file doesn't exist, there should be a single *.ini file in the datafiles, so attach that instead.

comment:8 Changed 7 years ago by digitall

scoriae: Just found that you originally reported this as a follow-on comment on bug #3485018 - "COMPOSER: v1 undetected MD5's": https://sourceforge.net/tracker/index.php?func=detail&aid=3485018&group_id=37116&atid=418820

Since this original bug is effectively fixed, I am closing that and transferring any relevant information to this bug:
Three games all affected in the same way ie.
1. Baba Yaga and the Magic Geese
2. Imo & The King
3. The Little Samurai

fuzzie: Are the game files (both book.ini and the resources) all in a single
directory on the CD?

scoriae: No, there is a book.ini in a program folder. Within the program folder are
three more folders, Menu, Play, and Story.

Using The Little Samurai as an example,

Menu folder contains:
CREDITS, END, FMENU, INTRO, MENU, MPAGES, RETAIL2, SPLASH, and TITLE RSC
files.

The play folder contains 12 files named PAGE1-PAGE12 with an RSC
extension.

The Story folder contains files named STORY0-STORY13 with an RSc
extension.

I tried detecting the game both with files in original folders and with all
files dumped into one folder.

Games are now detected, but all three crash after launch. Console
displays:

Assertion failed: isValidName(section), file common/config-file.cpp, line
289

The Little Samurai - book.ini supplied to help

Changed 7 years ago by digitall

Attachment: BOOK.INI added

The Little Samurai - book.ini

comment:9 Changed 7 years ago by digitall

scoriae: I think the issue here is that fuzzie knew that the Composer engine uses common/config-file.cpp to decode a top level ini file contains pathnames to resource files which it then "mangles" i.e. converts to real pathnames and assumed that the problem in the book.ini decoding... but I think the issue is the base datafile name you are using contains brackets.

As previously suggested, try this:
"The issue may be related to the brackets in the game data paths.
Please can you try removing both entries again or starting with no file
present, and rename both of your game data
directories to not have the "(CD Windows)" i.e. rather than
Z:\ScummVM\Imo & The King (CD Windows)\, say
Z:\ScummVM\Imo & The King CD Windows\ and then re-add and try them."

If this still fails, then please attach another book.ini from one of the games and a text file containing a file listing of that games' datafiles with md5sums... The output of a tool such as http://md5summer.org/ would be optimal.

comment:10 Changed 7 years ago by SF/scoriae

Ok, lots to cover here. I did attempt to add them again without the parenthesis in the folder name and I got the same error. All of my scummvm games, including my other living books, work fine with those parenthesis, so I didn't expect that to be a cause.

I also confirmed that baba yaga has the same crash still, so this affects all three of these games.

In dumping the files from my CD I retained the original directory structure. I experimentally tried dumping them all in one folder, but that doesn't even show the MAGIC BOOKS title screen if I do that.

I compared the MD5's from the book.ini you posted to the one in my little samurai folder and they were identical.

Attached is the MD5 for the Little Samurai subfolder.

One possible concern is that the book.ini doesn't only call for the files to be in the MENU, PLAY, and STORY subfolders... but it seems to suggest they are all under a folder named SAMURAI.

ex:
1=~:\samurai\menu\intro.rsc

I attempted to create a folder named SAMURAI and place the three game folders in it, but this failed.

I also tried editing the book.ini to remove references to the samurai folder, but then it changed the md5 and was no longer detected by scummvm.

However, maybe this isn't such a big deal, because just having the files in my current structure I at least get the title screen, so we know it is at the very least locating that first resource.

Changed 7 years ago by SF/scoriae

Attachment: The Little Samurai.md5 added

md5 of The Little Samurai's contents.

comment:11 Changed 7 years ago by wjp

Thanks for the extra info. We're pretty sure we know what the cause is now, but fixing it may take a little time. We'll let you know when we have something to test.

comment:12 Changed 7 years ago by SF/scoriae

glad to have helped.

comment:13 Changed 7 years ago by fuzzie

Should be fixed in 87b79f21. I'd be grateful if you could check your games with the next daily build. Thanks for being patient.

comment:14 Changed 7 years ago by digitall

Resolution: fixed
Status: newpending

comment:15 Changed 7 years ago by SF/scoriae

Yes, all 3 launch now. Great work =)

comment:16 Changed 7 years ago by SF/scoriae

Status: pendingnew

comment:17 Changed 7 years ago by digitall

scoriae: Thank you for confirming. Closing as fixed.

comment:18 Changed 7 years ago by digitall

Status: newclosed
Note: See TracTickets for help on using tickets.