Opened 7 years ago

Closed 7 years ago

#6006 closed defect (fixed)

SCI: KQ1 Engine Abort with Cursor Error Launching Game

Reported by: SF/envisaged0ne Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 1

Description

When you try to launch the game, it displays an error message "cursor 997's hotspot (0,256) is out of range of the cursors dimensions (16x16)!".

Using latest daily build on Win7 32 bit ultimate.

Ticket imported from: #3503932. Ticket imported from: bugs/6006.

Change History (6)

comment:1 Changed 7 years ago by digitall

Summary: Error when launching gameSCI: KQ1 Engine Abort with Cursor Error Launching Game

comment:2 Changed 7 years ago by digitall

Owner: set to bluegr

comment:3 Changed 7 years ago by digitall

envisagedOne: This is due to new sanity checks added in c87657f066ca9cbb0e07963c31cf57c96b1c5068 to catch cursors with bad hotspots, though this was only thought to affect Laura Bow 1 i.e.
c87657f066ca9cbb0e07963c31cf57c96b1c5068

SCI: Added some sanity checks by digitall

- Limit the LB1 cursor workaround to LB1 only (so that fanmade games
aren't affected)
- Error our when bad cursor hotspots are found

bluegr: Can you take a look at this? Extend the workaround for KQ1 or are we missing something about the meaning of cursors with out of range hotspots?

comment:4 Changed 7 years ago by wjp

The LB1-specific workaround was the cursor color, and unrelated to hotspots. The hotspot fix you are probably referring to is not game-specific; see c48ad37244e3706972b538616d0c0ce6653b4c68 and b21f956790075f11fff4b43cecb8afca368594b3.

This particular hotspot bug already existed before these changes, but just resulted in a missing cursor at startup, which is only really noticable when comparing it side-by-side with dosbox. The sanity checks you added have uncovered this.

comment:5 Changed 7 years ago by bluegr

Keywords: script removed
Resolution: fixed
Status: newclosed

comment:6 Changed 7 years ago by bluegr

Fixed in d801186 - it was caused by an incorrect version check

Closing

Note: See TracTickets for help on using tickets.