Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5988 closed defect (invalid)

DREAMWEB: Global constructors degrades portability

Reported by: fingolfin Owned by:
Priority: normal Component: Engine: Dreamweb
Keywords: Cc:
Game: Dreamweb

Description

The DREAMWEB engine makes use of global constructors, which reduces portability. Here's the relevant error / warning from clang.

C++ engines/dreamweb/people.o
../../engines/dreamweb/people.cpp:27:31: error: declaration requires a global constructor
[-Werror,-Wglobal-constructors]
static void (DreamWebEngine::*reelCallbacks[57])(ReelRoutine &) = {
^ ~
1 error generated.
make: *** [engines/dreamweb/people.o] Error 1

Ticket imported from: #3492135. Ticket imported from: bugs/5988.

Change History (4)

comment:1 Changed 7 years ago by lordhoto

What clang version is that?

Can't reproduce this with:
clang version 3.1 (trunk 151291)
Target: x86_64-unknown-linux-gnu
Thread model: posix

comment:2 Changed 7 years ago by fingolfin

This was with Apple clang version 3.0 (tags/Apple/clang-211.10.1). However, I cannot reproduce this with a current trunk build of clang either, so I am closing this as invalid. Sorry for the confusion!

comment:3 Changed 7 years ago by fingolfin

Resolution: invalid
Status: newclosed

comment:4 Changed 7 years ago by digitall

Component: Engine: Dreamweb
Game: Dreamweb
Note: See TracTickets for help on using tickets.