Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#5986 closed defect (fixed)

AGOS: Simon1 Amiga CD32 Verb Area missing

Reported by: SF/zaurak Owned by: Kirben
Priority: high Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

Version:ScummVM 1.5.0git2166-g1452327 (Jan 30 2012 11:39:37)
System: Windows XP SP3
Game: Simon the Sorcerer, Amiga CD32, English version

After entering the dwarf mine, the complete inventory, verbs and command line are invisible. They remain invisible for the rest of the game, even after leaving the dwarf mine. The original game on Amiga works fine in this situation.

Attached is a save game. After loading, do enter the dwarf mine (using the password "beer") to reproduce the bug.

Ticket imported from: #3490185. Ticket imported from: bugs/5986.

Attachments (8)

simon1.000 (806 bytes) - added by SF/zaurak 7 years ago.
Save game
Simon1-CD32-01.png (163.9 KB) - added by SF/zaurak 7 years ago.
Screenshot before entering the dwarf mine
Simon1-CD32-02.png (91.4 KB) - added by SF/zaurak 7 years ago.
Screenshot after entering the dwarf mine
Simon1-CD32-03.png (50.0 KB) - added by SF/zaurak 7 years ago.
Screenshot after entering the dwarf mine (Amiga)
simon1-en-amigacd32.txt (19.2 KB) - added by SF/zaurak 7 years ago.
Amiga CD32 Simon 1 datafiles
simon1.2.000 (915 bytes) - added by SF/zaurak 7 years ago.
Save game (2nd time the bug occurs during the game)
simon1-normal.txt (37.5 KB) - added by eriktorbjorn 6 years ago.
Debug log when running normally (with the glitch)
simon1-valgrind.txt (61.2 KB) - added by eriktorbjorn 6 years ago.
Debug log when r unning in Valgrind (without the glitch)

Download all attachments as: .zip

Change History (25)

Changed 7 years ago by SF/zaurak

Attachment: simon1.000 added

Save game

Changed 7 years ago by SF/zaurak

Attachment: Simon1-CD32-01.png added

Screenshot before entering the dwarf mine

Changed 7 years ago by SF/zaurak

Attachment: Simon1-CD32-02.png added

Screenshot after entering the dwarf mine

comment:1 Changed 7 years ago by digitall

Summary: Simon1: Inventory disapears after entering the dwarf mineAGOS: Simon1 Amiga CD32 Inventory Problem at Dwarf Mine

comment:2 Changed 7 years ago by digitall

Savegame attached can be loaded in Simon 1 CD Windows (after renaming to simon1.001). Entering the mine there doesn't replicate this issue and running with Valgrind shows no issues.

I suspect that this is a script issue with our AGOS interpreter and the Amiga CD32 version's scripts i.e. the game thinks a dialog is occuring and thus the bottom of the screen is blanked to be overwritten by the dialog options/text... but this is never exited.

zaurak: We need to check a few things here:
1. Can you check with your savegame, if this happens with the latest stable i.e. v1.4.1 ?
2. Can you please attach a file listing of your Amiga CD32 Simon 1 datafiles with sizes and file MD5sums as a text file to this bug? The output of a tool such as http://md5summer.org/ would be optimal.
This will allow us to exactly identify your version, and check for any corrupted/truncated datafiles which may be causing this.

Apart from this, this may take some investigation by a AGOS engine developer with this rarer game variant, so please be patient and standby...

Changed 7 years ago by SF/zaurak

Attachment: Simon1-CD32-03.png added

Screenshot after entering the dwarf mine (Amiga)

Changed 7 years ago by SF/zaurak

Attachment: simon1-en-amigacd32.txt added

Amiga CD32 Simon 1 datafiles

comment:3 Changed 7 years ago by SF/zaurak

1. The bug is also present using ScummVM 1.4.1 with the same save game.
2. The textfile with sizes and MD5sums is attached.

Further, attached is a screenshot from Amiga.

Your idea seems to lead to the right direction. After Simon enters the dwarf mine and speaks the last sentence to the gate keeper ("Right on!"), the inventory appears for a very short time using ScummVM, but suddenly disapears and keeps hidden. On Amiga the inventory also appears after that sentence, but keeps present.

comment:4 Changed 7 years ago by SF/zaurak

I have investigate a bit further... Simon stands inside the dwarf mine. The inventory is invisible. Simon leaves the dwarf mine and heades two times to the east. Then Simon talks with the woodcutter (blind assuming the right verb from the inventory and blind assuming the answers - they are also hidden). After the talk is finished, the inventory is back visible (but disapears again when entering the dwarf mine the next time).

comment:5 Changed 7 years ago by SF/zaurak

It seems to be Amiga-related. The same bug also occurs in the German Amiga disk version of Simon1 using the same save game.

comment:6 Changed 7 years ago by digitall

Owner: set to Kirben

comment:7 Changed 7 years ago by digitall

zaurak: Thanks for this information. One of our AGOS developers has managed to replicate this with Amiga CD32 and will try to locate and fix this in due course. Please be patient...

Changed 7 years ago by SF/zaurak

Attachment: simon1.2.000 added

Save game (2nd time the bug occurs during the game)

comment:8 Changed 7 years ago by SF/zaurak

The same bug occurs a second time during the game. The inventory disapears again after entering the teleporter and transfering to the pits of Rondor (save game attached).

comment:9 Changed 7 years ago by sev-

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:10 Changed 7 years ago by sev-

Priority: normalhigh

comment:11 Changed 6 years ago by eriktorbjorn

I tried running this in Valgrind. I didn't get any warnings, but I also did not get the buggy behaviour when I did that. Maybe it's timing-sensitive?

comment:12 Changed 6 years ago by Kirben

This problem is inconsistent and doesn't always occur, which is why I have not been able to track down the cause.

comment:13 Changed 6 years ago by eriktorbjorn

It always happens for me when playing normally, and never when I use Valgrind. Unfortunately, I have trouble debugging it since I don't really know what I'm looking for.

Adding some rather random debug messages, I did notice that in Valgrind, it will call vc22_setPalette() a few more times than it does when playing normally. Could that be significant? Right now, the debug messages I get look like this when I get the glitch:

WARNING: VocStream::preProcess: Caught 128 as terminator!
vc22_setPalette(14, 3)
vc22_setPalette(15, 3)
vc22_setPalette(13, 3)
vc62_fastFadeOut
There was no previous fast fade out flag
_fastFadeCount = 208
fadeCount = 64, fadeSize = 4
_windowNum = 4
vc22_setPalette(0, 0)
vc22_setPalette(3, 1)
vc22_setPalette(4, 2)
vc22_setPalette(5, 3)
vc22_setPalette(6, 4)
vc22_setPalette(7, 5)
vc22_setPalette(8, 6)
vc22_setPalette(12, 7)
vc63_fastFadeIn

When I don't get the glitch, they look like this instead:

WARNING: VocStream::preProcess: Caught 128 as terminator!
vc22_setPalette(14, 3)
vc22_setPalette(15, 3)
vc22_setPalette(13, 3)
vc22_setPalette(14, 0)
vc22_setPalette(15, 2)
vc22_setPalette(13, 1)
vc62_fastFadeOut
There was no previous fast fade out flag
_fastFadeCount = 208
fadeCount = 64, fadeSize = 4
_windowNum = 4
vc22_setPalette(0, 0)
vc22_setPalette(3, 1)
vc22_setPalette(4, 2)
vc22_setPalette(5, 3)
vc22_setPalette(6, 4)
vc22_setPalette(7, 5)
vc22_setPalette(8, 6)
vc22_setPalette(12, 7)
vc63_fastFadeIn

Changed 6 years ago by eriktorbjorn

Attachment: simon1-normal.txt added

Debug log when running normally (with the glitch)

Changed 6 years ago by eriktorbjorn

Attachment: simon1-valgrind.txt added

Debug log when r unning in Valgrind (without the glitch)

comment:14 Changed 6 years ago by eriktorbjorn

I've attached two logs where I activated as much debug output as I could find when the game is waiting for the dwarf mine password: One when running normally (with the glitch) and one when running in Valgrind (without the glitch).

I don't really know how to interpret them though. I did see that it appears to do some palette manipulation when it works that isn't there when it doesn't. But I don't know why, or if that's what causes the inventory to disappear.

comment:15 Changed 4 years ago by Kirben

Resolution: fixed
Status: newclosed
Summary: AGOS: Simon1 Amiga CD32 Inventory Problem at Dwarf MineAGOS: Simon1 Amiga CD32 Verb Area missing

comment:16 Changed 4 years ago by Kirben

The problem was due to original Amiga versions needing to wait for the verb area to be drawn, which was missing in ScummVM.

Fixed in ScummVM GiT, use the next daily snapshot of ScummVM Git.

comment:17 Changed 4 years ago by SF/zaurak

Works fine using latest snapshot. Finally fixed! :-)

Note: See TracTickets for help on using tickets.