Opened 8 years ago

Closed 8 years ago

#5953 closed defect (invalid)

SCUMM: Freddi 2 Crash on (S)ave/(L)oad Hotkey

Reported by: SF/stvmuser Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Freddi Fish 2

Description

Freddi 2 Haunted Schoolhouse crashes when the S key is presses for saving (or L for load). Playing 1.4.1 on a Mac Powerbook G4 Mac OS 10.3.9.

Ticket imported from: #3481159. Ticket imported from: bugs/5953.

Change History (12)

comment:1 by digitall, 8 years ago

Summary: Crash upon savingSCUMM: Freddi 2 Crash on (S)ave/(L)oad Hotkey

comment:2 by digitall, 8 years ago

stvmuser: Thank you for this bug report.

Can you please provide a listing of your Freddi 2 datafiles with md5sums as a text file and attach to this bug...
The output of a tool such as http://md5summer.org/ would be optimal.
Basically, file names, sizes in bytes, file md5sum and restricted detection md5sum ( See http://wiki.scummvm.org/index.php/Reporting_unknown_MD5_checksums) would be perfect..

This will allow us to eliminate corrupted datafiles/media as a cause.

comment:3 by SF/stvmuser, 8 years ago

This is from checsum+ I have installed. If you really need the restricted detection sum, let me know, I will try to get a program to do that. I don't think the i or r files below are required, but I included them in case it helps.

File name,
bytes
MD5

Freddi Fish 2 (0)
65413
51305e929e330e24a75a0351c8f9975e
Freddi Fish 2 (2)
34564440
2f0f418ca29e298343a76e4a76ce5d96
Freddi Fish 2 (4)
42596874
c87140d52e550ee923f18789517e61ab
Freddi Fish 2 (a)
115340334
722286b727e75a3e44f9333d6b604427
Freddi Fish 2 (i)
444
d5920b5082d570d03500fe165bb75c0a
Freddi Fish 2 (r)
0
d41d8cd98f00b204e9800998ecf8427e

comment:4 by digitall, 8 years ago

stvmuser: Thanks. This should be sufficient. Please standby... We need to find a developer with a copy of this game to check...

comment:5 by Kirben, 8 years ago

I'm unable to reproduce the issue, using the Macintosh HE99 version of Freddi Fish 2, with ScummVM in Windows XP.

I don't notice any attempts to open files with invalid filenames either, so not sure what could be causing a crash.

comment:6 by digitall, 8 years ago

Kirben: Thanks for looking at this. Does your version's datafile MD5sums match those given by the bug submitter?

comment:7 by Kirben, 8 years ago

Yes, the MD5sums of the datafiles I'm using, match the bug submitter exactly.

comment:8 by SF/stvmuser, 8 years ago

If it workied in Windows, could it be a port bug? criezy has a mac laptop running the same OS version.

His mac was used to reproduce bug #3437529

comment:9 by SF/stvmuser, 8 years ago

On a hunch, I looked at the files in the game folder. There were save game files from back in 2009. I deleted the files, and now the save and load seem to work fine. Sorry about taking up your time.

comment:10 by SF/stvmuser, 8 years ago

Resolution: invalid

comment:11 by digitall, 8 years ago

stvmuser: Thank you for spending the time to inform us of this. Closed on Invalid/Outdated...

comment:12 by digitall, 8 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.