Opened 8 years ago

Closed 7 years ago

#5917 closed defect

TINSEL: Discworld (Polish) Detection Regression

Reported by: SF/aragothestel Owned by: dreammaster
Priority: high Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld

Description

Android client v1.4.0 is unable to add polish version of Discworld. English version of this game works perfectly, when I try to add polish version, I get error that no game is found.
Polish version has modified \'DW.GRA\' file - there are probably modified fonts with polish charset (see attachment). This modified version works without any problems in Windows\' ScummVM.

Ticket imported from: #3452365. Ticket imported from: bugs/5917.

Attachments (4)

DW.rar (196.7 KB ) - added by SF/aragothestel 8 years ago.
Polish version of DW.GRA
DiscworldPL.md5 (9.1 KB ) - added by SF/aragothestel 8 years ago.
MD5 sums of polish version of Discworld
scumm121.png (18.0 KB ) - added by SF/aragothestel 8 years ago.
Modified ScummVM 1.2.1 screenshot
scummvm-1.4.1-dwpl.patch (1.7 KB ) - added by SF/aragothestel 7 years ago.
Modified ScummVM source

Download all attachments as: .zip

Change History (27)

by SF/aragothestel, 8 years ago

Attachment: DW.rar added

Polish version of DW.GRA

comment:1 by digitall, 8 years ago

aragoth: Thank you for the bug report. This is a bit surprising since the Advanced detector code is the same for both Android and Windows builds. To help advance this bug investigation, could you provide the following:
1. The ScummVM Windows version that detects fine.. i.e. is this v1.4.0 stable? If not, please test with v1.4.0 Win32 build.
2. Please can you attach a text file to this bug containing a file listing of your Discworld 1 (Polish) datafiles, preferably with MD5sums. The output of a tool such as http://md5summer.org/ would be optimal. This will help identify your exact version.

comment:2 by digitall, 8 years ago

Also, could you please confirm that on Android, you have installed the ScummVM plugin: tinsel i.e. the Tinsel engine used to support Discworld?

comment:3 by digitall, 8 years ago

Summary: Polish version of Discworld is not workingTINSEL: Discworld (Polish) not detected on ANDROID

comment:4 by SF/aragothestel, 8 years ago

tdhs: thanx for your reply. I confirm that tinsel plugin is installed, english version of DW works perfectly. Windows ScummVM version, which was able to detect polish version of DW, was 1.2.1. After upgrading to 1.4.0, game cannot be added and previously added game doesn't work, so it behaves the same as Android version.

I'll attach MD5 sums in a moment. There are two files, that are different than english version:
ENGLISH.TXT - dialogs translated to PL
DW.GRA - not sure, probably it has something in common with fonts used in the game. After replacing polish version of DW.GRA with english one, game is discoverable and playable in ScummVM but there are no polish 'special' signs (ś, ą, ń etc.)

by SF/aragothestel, 8 years ago

Attachment: DiscworldPL.md5 added

MD5 sums of polish version of Discworld

comment:5 by digitall, 8 years ago

Summary: TINSEL: Discworld (Polish) not detected on ANDROIDTINSEL: Discworld (Polish) Detection Regression

comment:6 by digitall, 8 years ago

aragoth: Thanks for confirming this. It would appear to be a regression in the Tinsel engine game detection.
Could you please try with Win32 releases v1.3.0 and v1.3.1, and report the results here?
This way we can narrow down the point of regression between 1.2.1 (where this worked) and v1.4.0 (where it does not).

Looking at the tinsel detection tables, I can't find an entry for the Polish variant, which may meant that this was using a fallback general detection, which is now not working. Could you also please try running the v1.4.0 win32 build from a DOS command line, attempt to add game of your Polish version and then attach any output from the DOS console window? i.e. The easy method noted on http://wiki.scummvm.org/index.php/Reporting_unknown_MD5_checksums

comment:7 by SF/aragothestel, 8 years ago

I tried to run DW using v1.3.1 and 1.3.0 and there was the same problem. What is strange - I downloaded v1.2.1 from sourceforge and this version isn't able to run DW, too. I noticed, that my 'old' v1.2.1 exe has different size and build date than sourceforge version (see attached file). I downloaded my 1.2.1 working version with game - so I think it's possible that somebody changed ScummVM source to get DW working and deployed EXE independently. Before downloading original v1.2.1 i didn't know, that my version differs from the original one.

Output from console window:
The game in 'D:\Gry\ScummVM\Games\DiscWorld\' seems to be unknown.
Please, report the following data to the ScummVM team along with name
of the game you tried to add and its version/language/etc.:
{"dw.gra", 0, "ef05bbd2a754bd11a2e87bcd84ab5ccf", 781864},
{"english.txt", 0, "c1a53eb7ec812689dab70e2bb22cf2ab", 224151},

So, after checking a few older versions of ScummVM now I think, that there was no support for polish version of Discworld (there is also one more unsupported version, with different file extensions - *.scn instead of *.gra). The question is - can you add support for polish DW in future versions of ScummVM? ;)

by SF/aragothestel, 8 years ago

Attachment: scumm121.png added

Modified ScummVM 1.2.1 screenshot

comment:8 by digitall, 8 years ago

aragothestel: To be clear, is the Polish version of Discworld an official relase or a fan translation from the english version?

comment:9 by SF/aragothestel, 8 years ago

tdhs: I'm not sure, if it is official or fan translation - anyway, this is the only polish version I found, I guess that it's the only existing polish version (besides the one with .SCN file extension)

comment:10 by digitall, 8 years ago

Ah right.. Where did you find this version?

comment:11 by SF/aragothestel, 8 years ago

I downloaded polish version from web page with old, abandoned games (probably staregry.org.pl). I don't remember, where I found version with ScummVM.

comment:12 by digitall, 8 years ago

I'm sorry, but we will never support abandonware / warezed versions, especially if they have been modified.
We only support fan translations as patches to an original game release datafiles.

Buy a legal copy of the game.
http://wiki.scummvm.org/index.php/Copyright_FAQ

comment:13 by digitall, 8 years ago

Resolution: wontfix
Status: newclosed

comment:14 by SF/aragothestel, 8 years ago

Ok thanks for your information, I'll try to find out more about this translation.

comment:15 by SF/aragothestel, 8 years ago

tdhs: I discovered that polish version of Discworld is a fan translation made by:
Johnny - translation
Manuel Czaszka - correction
twig - scripting tools
Dimouse - font and graphics

Path that modifies original game can be found here: http://grajpopolsku.pl/news.php?readmore=248 or direct link to zip file here: http://grajpopolsku.pl//dwn/rom/pc/discworld_pl_v1.00.7z

There's also newer version of this path (v1.02), with support for both versions of Discworld and some other corrections (GRA and SCN file extensions) here: http://scummpl.grajpopolsku.pl/downloads.php?cat_id=1&download_id=17 or direct link http://grajpopolsku.pl/dwn/rom/pc/DWPLv1.02.zip - in newer version you'll find... modified ScummVM application, that is able to run polish version of Discworld ;) So I think that someone has pre-pathed this game and put on web page with abandonware mentioned before.

comment:16 by digitall, 8 years ago

Resolution: wontfix
Status: closednew

comment:17 by sev-, 7 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:18 by sev-, 7 years ago

Owner: set to dreammaster
Priority: normalhigh

comment:19 by dreammaster, 7 years ago

Hey, aragothestel, I see the 1.02 release comes with a specially compiled version of ScummVM. Since that's the case, can you speak to them about providing the added detection entries for the patched version? It's just that their patche programs are Windows executables, and I'm a bit wary of just directly running them on my home system.

comment:20 by SF/aragothestel, 7 years ago

Hello, dreammaster. I actually don't know authors of this path. Anywah, I'll try to e-mail them, but I don't even know, if e-mail shown in readme is still active. Hope that I'll get any response :)

BTW I tried to run polish version of Discworld with original ScummVM and as far as can I remember, I had only to restore original DW.GRA (modified version attached below). It was some time ago and currently I'm unable to verify it. I can provide more help when I'm back home (in 2 days). If you could compile test version of ScummVM, I'm able to verify, if it works properly.

by SF/aragothestel, 7 years ago

Attachment: scummvm-1.4.1-dwpl.patch added

Modified ScummVM source

comment:21 by SF/aragothestel, 7 years ago

Hello again :)
I attached modified version of ScummVM source. E-mail was active and response came very quick :) Hope that'll help.

comment:22 by dreammaster, 7 years ago

Patch accepted and committed.

comment:23 by dreammaster, 7 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.