Opened 8 years ago

Closed 8 years ago

#5792 closed defect (fixed)

Game not found by 1.3.0

Reported by: SF/stvmuser Owned by: digitall
Priority: normal Component: Engine: SCI
Keywords: detection Cc:
Game: Slater & Charlie Go Camping

Description

I got this message when trying to add either the windows or dos version of the game. The disk is a 'Sierra originals' so is a later release. Language is English.

The game in '/Users/st/Slater' seems to be unknown.

Please, report the following data to the ScummVM team along with name

of the game you tried to add and its version/language/etc.:

{"resource.000", 0, "d7b4cc8e2c0b3a4768f8dfb5de27f206", 2256126},

{"resource.map", 0, "21f85414124dc23e54544a5536dc35cd", 4044},

{"resource.msg", 0, "c44f51fb955eae266fecf360ebcd5ad2", 1132},

Thanks!

Ticket imported from: #3359182. Ticket imported from: bugs/5792.

Change History (10)

comment:1 Changed 8 years ago by digitall

5x7: Your resource.000 md5sum differs from the expected value, though the length is identical.
The other files match in both length and md5sum.

Could you check that this is not a media copying error?

Also attaching a text file wih the full CD file listing with md5sums i.e. use a tool like MD5summer (http://md5summer.org/) or similar would be useful as it would enable the SCI devs to identify the specific version and identify if any changes are needed for the later release.

comment:2 Changed 8 years ago by SF/stvmuser

As for a file copy error, I get the same '..not find any game..." message when I try to add it directly form the CD, which is new condition, too.

Is there an MD5 tool for mac os? http://md5summer.org is windows.

Would it help if I attached resource.000?

comment:3 Changed 8 years ago by SF/stvmuser

I did copy the files from the CD to the hard drive twice with the same results, so I don't think it is a copy error.

comment:4 Changed 8 years ago by SF/stvmuser

I used a product called checksum+ which gave the following for resource.000

a4bbc7e107a4fcde8eb71bce4350b063, same byte length

I should mention that checksum+ is for a more advanced mac os than I have so I hope the results are OK. Both the windows and dos resource.000 returned the same result.

comment:5 Changed 8 years ago by digitall

stvmuser: OK, no problem. Looks like you have an older release version, which has been unknown until now.
Will add detection for this. Standby.

comment:6 Changed 8 years ago by digitall

Detection Entry added in 6355ccc677d5b7f167d5ea9a03f1cf08248e91e9.

5x7: Please test the daily development builds (master) over the next couple of days to check this works correctly:
http://www.scummvm.org/downloads/#daily

comment:7 Changed 8 years ago by digitall

Owner: set to digitall

comment:8 Changed 8 years ago by SF/stvmuser

It detected in yesterday's build. Thanks!!

comment:9 Changed 8 years ago by SF/stvmuser

Resolution: worksforme

comment:10 Changed 8 years ago by wjp

Resolution: worksformefixed
Status: newclosed
Note: See TracTickets for help on using tickets.