Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5712 closed defect (fixed)

SQ1 Apple IIgs: music problems with game v2.2

Reported by: SF/jklaiho Owned by:
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 1

Description

Apologies if this is a known issue, but a quick rummage through various sources didn\'t reveal any relevant information about this.

Using a daily build of ScummVM (1.3.0pre67-g793849c), I acquired the disk images of Space Quest 1 for the Apple IIgs in 2mg format. I extracted the required files as listed by the Datafiles page on the wiki using CiderPress (a Windows software for handling various IIgs disk image formats) and added them to ScummVM.

ScummVM identifies the files with the following version string: \"2.2 1987/Apple IIgs/English\". Starting the game, it\'s immediately obvious that the music isn\'t reproduced properly. I\'ve made a recording of one full loop of the intro music, followed at about 0:51 by the first sound effects of the game, the opening and closing of the closet doors and a speech sample blaring \"Battle stations!\" It\'s available here: http://dl.dropbox.com/u/2287394/SQ1_IIgs_music_flaw.mp3

I also have the 1.5D version of SQ1 from 1987 for the Macintosh. There the intro music plays back flawlessly (I think), but the in-game sound effects are different: the door sound is much slower and there is no speech sample. This is probably a legit version difference, but someone may want to confirm that (I didn\'t use to own either a IIgs or an original Macintosh, so I don\'t know).

If necessary, I can provide the game files for testing. Since they\'re under copyright, I won\'t post them here but you can contact me privately at jklaiho at iki dot fi and I\'ll send them to you.

Ticket imported from: #3307080. Ticket imported from: bugs/5712.

Change History (10)

comment:1 by SF/jklaiho, 9 years ago

Argh, SF seems to have messed up the escaping of my quotation marks. Sorry about that.

comment:2 by digitall, 9 years ago

This is a known issue and is being worked on as part of GSoC 2011:
http://wiki.scummvm.org/index.php/AGI/TODO#Not_Yet_Implemented
https://github.com/scummvm/scummvm/pull/9

This correction is unlikely to be merged prior to the v1.3.0 release, but I would suggest testing a 1.4.0pre daily build once the pull request is integated, to see if this fixes your issues.

comment:3 by SF/jklaiho, 8 years ago

Excellent. I'll do that.

comment:4 by fingolfin, 8 years ago

This is a known and documented limitation, see <http://www.scummvm.org/compatibility/DEV/sq1/>.

Somebody is working on improving the situation, though, see also this GIT pull request: <https://github.com/scummvm/scummvm/pull/9>.

I know you mean only well with your offer to send us game data files privately, but this is still not legal, and we cannot accept this offer.

comment:5 by fingolfin, 8 years ago

Sorry for the duplicate comment, somehow I missed tdhs earlier one (SF.net folded the "comments" section, and I overlooked the small indicator "(3)" which should have told me comments already exist ... *sigh*)

comment:6 by SF/jklaiho, 8 years ago

Looks like the pull request was merged a couple of days ago. I downloaded the latest daily build just now, but unfortunately the issue remains. The music, as far as I can tell, is unchanged.

comment:7 by digitall, 8 years ago

jklaiho: That is expected. Currently, daily builds are being built for "stable" i.e. v1.3.0 release branch.
It is expected that this will switch to the "master" development i.e. v1.4.0pre, at some point fairly soon.
At this point, the builds at http://buildbot.scummvm.org/builds.html will be xxx-master instead of xxx-stable.

comment:8 by SF/jklaiho, 8 years ago

tdhs: Ah, I didn't realize that.

So, having learned of this, I cloned the git repo and built the current master branch manually (1.4.0git635-gbea6858), and I'm happy to report that the music seems to work flawlessly! Looks like the merged pull request did the trick.

How accurate it is compared to the original, I'm unable to say, but it sounds very good as it is.

comment:9 by SF/jklaiho, 8 years ago

I'll go ahead and close the issue.

comment:10 by SF/jklaiho, 8 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.