Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5689 closed defect (fixed)

SCI: JONES: Graphics corruption

Reported by: SF/psycrow7 Owned by: wjp
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Jones in the Fast Lane

Description

When enrolling in classes as the University, the dialog box image is corrupt where it overlaps the "actor" image.
This is with the English CD version tested on win32 and can by reproduced at the start of the game by going straight to the university and enrolling in a class.

Ticket imported from: #3297111. Ticket imported from: bugs/5689.

Attachments (1)

Jones.png (23.4 KB) - added by SF/psycrow7 8 years ago.
Shows corruptions over the professors face.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by SF/psycrow7

Attachment: Jones.png added

Shows corruptions over the professors face.

comment:1 Changed 8 years ago by SF/mthreepwood

Summary: Graphics corruptionJONES: Graphics corruption

comment:2 Changed 8 years ago by bluegr

Priority: normallow

comment:3 Changed 8 years ago by bluegr

Priority: lownormal

comment:4 Changed 8 years ago by wjp

Summary: JONES: Graphics corruptionSCI: JONES: Graphics corruption

comment:5 Changed 8 years ago by wjp

Partially fixed by 9e2c7f26d2e6c6081489365cbc07cd6edec362ad.

The remaining issue in the corners seems to be caused by the erase rect in KDrawControl(text) being too large, but that should be investigated properly.

comment:6 Changed 8 years ago by wjp

More research:

The problem wasn't the erase rectangle, but rather the showbits rectangle which seems too big.

However, according to the same logic, the showbits rectangle in KDrawControl(Button) is also too large, but changing that breaks buttons..

comment:7 Changed 8 years ago by wjp

And now fixed in 4c70d399330503e39841d6047435e26da2f189f2.

comment:8 Changed 8 years ago by wjp

Owner: set to wjp
Resolution: fixed
Status: newclosed

comment:9 Changed 8 years ago by wjp

P.S. There are still some pixel-sized glitches in the corners of some dialogs, but the ones I've seen match the original perfectly.

Note: See TracTickets for help on using tickets.