Opened 9 years ago

Closed 8 years ago

#5673 closed defect (fixed)

AGI: SQ2: Name forgotten after game restart

Reported by: SF/mokeiichi Owned by: bluegr
Priority: normal Component: Engine: AGI
Keywords: script Cc:
Game: Space Quest 2

Description

When starting the game, you can enter a name, which will be used in the game. When you restart the game using F9 or the menu, this name will be blank (ie. "")
To reproduce this bug:
Start game
Enter any name or leave blank for "Roger Wilco"
wait till watch beeps
type: look watch
type: c
A message gets displayed, beginning with your name
Restart the game using F9 or menu entry
again wait till watch beeps
type: look watch
type: c
The message is missing your name (starts with an exclamation mark "!")
Doesn't happen with the original Sierra interpreter
Space Quest 2 v2.0f
ScummVM 4f708b0 (24.04.2011)

Ticket imported from: #3292784. Ticket imported from: bugs/5673.

Attachments (1)

SQ2-name-fix.patch (363 bytes ) - added by digitall 8 years ago.
Patch to fix for just SQ2 Name..

Download all attachments as: .zip

Change History (5)

comment:1 by SF/mokeiichi, 9 years ago

Summary: Name forgotten after game restartAGI: SQ2: Name forgotten after game restart

comment:2 by digitall, 8 years ago

Replicated with Latest Git master.

Traced cause to reset of _game.strings[] in AgiInit().
Tested attached patch which fixes this issue, but is limited to _game.strings[1].
It is probable that all _game.strings[] should not be reset when _restartGame is true, but since any patch here affects all AGI games, an AGI dev should review and make the relevant changes.

by digitall, 8 years ago

Attachment: SQ2-name-fix.patch added

Patch to fix for just SQ2 Name..

comment:3 by bluegr, 8 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:4 by bluegr, 8 years ago

Fixed in bc3c68c5088a39cf2befe5fba5bb2056643c4b4f, will be included in the next daily version.

Thanks for all the help digitall / tdhs :)

Note: See TracTickets for help on using tickets.