Opened 9 years ago

Closed 8 years ago

#5643 closed defect (fixed)

ScummTools do not compress monster.sou of german fdd-version

Reported by: SF/aborque Owned by: criezy
Priority: high Component: Tools
Keywords: Cc:
Game:

Description

Game: Sam& Max German FDD OS: Windows XP & 7 ScummVM-Tools (compress_scumm_sou) 1.2.0 Errormessage: "Fatal Error : Read beyond the end of file (monster.sou)" monster.sou is not corrupted (fresh install), MD5: F5AE8FAB1555981EB66B7B4AF5F57C7E, other files compress well Details: see below

Hello! While trying to build my ideal lucasarts collection based on ScummVM and my old games I am using ScummVM-Tools to compress the Soundfiles etc. using ogg-vorbis. Compressing monster.sou of the german fdd-version of Sam & Max Hit the road creates reproducible an error-message reading \"Fatal Error : Read beyond the end of file (monster.sou)\" with ScummVM-Tools 1.2.0 I believe this is an error in ScummVM tools (and not my fault or due to a corrupted monster.sou-file) as I a) reinstalled Sam & Max from my old disks without any errors and still can not compress the file and b) used ScummVM-Tools succesfully to compress german fdd-verion of DOTT and german CD versions of S&M and DOTT without any problems. Furthermore english monster.sou of S&M-FDD can also be compressed. I can provide a zipped version of my monster.sou (MD5 of my german fdd monster.sou is: F5AE8FAB1555981EB66B7B4AF5F57C7E) if needed for bug-tracking and fixing. Thanks for your investigation and perhaps a fix! A.Borque

Ticket imported from: #3280674. Ticket imported from: bugs/5643.

Change History (6)

comment:1 by SF/aborque, 9 years ago

Component: Engine: SCUMMTools
Game: Sam and Max

comment:2 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:3 by sev-, 9 years ago

Priority: normalhigh

comment:4 by SF/aborque, 8 years ago

It'S a structural problem with german monster.sou. Over at mixnmojo-forums a member kindly analyzed the original german fdd monster.sou and found out that it ends with a VTTL/VCTL tag not followed by any voice-data. So either the scumm-tools can be patched to handle this special situation or a small script removing developed by that mixnmojo-foum-member can be applied to the file. it removes the last ten bytes. Afterwards scumm-tools will work.

comment:5 by criezy, 8 years ago

Owner: set to criezy
Resolution: fixed
Status: newclosed

comment:6 by criezy, 8 years ago

This should be fixed now I have committed patch #3456593.

Note: See TracTickets for help on using tickets.