Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5553 closed defect (worksforme)

LB2: Frequent Speech Stuttering

Reported by: (none) Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Laura Bow 2: The Dagger of Amon-Ra

Description

Language: English
Version: CD Talkie ver 1.1
ScummVM version: 1.3.0svn54035 (x64, Nov 2, 2010)

The game suffers alot of stuttering speech audio. The earliest example can be heard at intro cutscene on the speech between the 2 gentleman on the dock. The second line which the right gentleman speaks stutters badly.

And not long after starting the game, the speech will stutter all the way. Although restarting ScummVM help fixing this problem, it will start stuttering again after awhile. Unless switching to text (or the floppy version), this is not really playable.

BTW, I'm playing this on my laptop's HDD, copied every content from the CD.

Kindly follow-up this request. Thx. :)

Ticket imported from: #3136085. Ticket imported from: bugs/5553.

Change History (16)

comment:1 by digitall, 9 years ago

AFAIK LSL2 does not have speech or CD version.

Please can you confirm the game and exact version as reported by ScummVM on detection and whether your speech files have been compressed in any way with tools.

Thanks.

comment:2 by digitall, 9 years ago

Based on the docks in the intro reference, we think you meant Laura Bow 2 : The Dagger Of Amon Ra.

Testing this with :
ScummVM 1.3.0svn54900 (Dec 13 2010 03:47:47)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora
on Linux x86_32, I get no stuttering in the CD audio.

Since your build is a nightly development build more than 1 month old,
could you download the latest nightly build of both v1.3.0 (Trunk) and v1.2.0 Branch and confirm whether this problem still occurs?

Thanks.

comment:3 by digitall, 9 years ago

Nightly builds can be found here :
http://buildbot.scummvm.org/builds.html

comment:4 by (none), 9 years ago

Game: Leisure Suit Larry 2Laura Bow 2: The Dagger of Amon-Ra

comment:5 by jvprat, 9 years ago

Summary: Frequent Speech StutteringLB2: Frequent Speech Stuttering

comment:6 by (none), 9 years ago

Summary: LB2: Frequent Speech StutteringFrequent Speech Stuttering

comment:7 by (none), 9 years ago

Sorry for that. It is for Laura Bow 2. I must have selected LSL2 by mistake.

Anyway, taken your suggestion. Updated to the latest SVN. The sound still stutters badly after few speeches. Tested with Dosbox and it seems plays fine for sometime.

Maybe there's a problem with the sound buffering or something?

comment:8 by jvprat, 9 years ago

Summary: Frequent Speech StutteringLB2: Frequent Speech Stuttering

comment:9 by digitall, 9 years ago

Thanks. This looks like it might be a leak in the sound system, but this may not be in ScummVM.

Please can you confirm your operating system and paste the output of "scummvm --version"?

From your comments, I assume you have checked out trunk SVN and built yourself.
If so, please could you confirm which instructions you are following from http://wiki.scummvm.org/index.php/Compiling_ScummVM and the exact compiler and SDL versions that you are building with.

As a minimum, could you please test with the precompiled Windows 32 bit and 64 bit builds as this may be a 64 bit compiler issue, and this can be confirmed if our precompiled binaries don't exhibit the issue.

comment:10 by (none), 9 years ago

Just found out something....

If I'm using Adlib as MIDI, the stuttering stopped. Haven't occurred to me again. But when I got back using MT32 Emulator as MIDI, it happens again.

Right now I'm using svn 54898 32 bit. Haven't tried the 64 bit version. Might do it later. Btw, the FluidSynth driver in this svn were not found.

My OS is Win7 Home Premium 64 bit. And I do not know about that compiling stuff. I just took the latest build from the provided link.

comment:11 by digitall, 9 years ago

Please see section 7.3 of the README specifically :
"NOTE: The processor requirements for the emulator are quite high; a fast
CPU is strongly recommended."
and http://forums.scummvm.org/viewtopic.php?t=7650&sid=882afcbda59b64b60931a6063ef247b5

The short answer is that the MT-32 Emulator is _very_ CPU intensive and
currently unoptimised, so this is causing the sound system to stutter due to lack of CPU.
This is a known problem.

The workaround is to use Adlib Emulation or SEQ MIDI (which allows you to connect ScummVM to your MT-32).

comment:12 by (none), 9 years ago

That's kinda weird though since before this, I have played Eco Quest Talkie version till finished with MT32 driver and not once did I find any stuttering in the game. And I think both games has similar requirements back when I'm playing using AT-286.

And by today's standard, I think processor requirements for this emulator are more than enough to run this, even with maxed out settings. And I think my laptop can be counted as one. Mine is ASUS UL30VT with Intel Core2duo 7300, 4GB DDR3 RAM and Nvidia GeForce G210M. This specs is quite enough to play current gaming streams like Dead Rising 2.

I already read the README file for couple times and already know about reqs issues. But I do think my specs are more than enough for this. Maybe there's code optimization needed here, it might takes times though.

comment:13 by bluegr, 9 years ago

Can you try with General MIDI? The music in LB2CD was optimized for GM

comment:14 by (none), 9 years ago

There's no General MIDI in ScummVM. The nearest equivalent is MS GS Wavetable Synth. And yes, it didn't stutter although I only tested like several minutes.

comment:15 by bluegr, 9 years ago

That's GM. It seems that your system can't handle he MT-32 emulator, which isn't a problem of the SCI engine itself. It works for me (and most other people), so closing it as such

comment:16 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.