Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5526 closed defect (wontfix)

AGI FAN: Beyond the Titanic 2 - Priority Problem

Reported by: raziel- Owned by: bluegr
Priority: normal Component: Engine: AGI
Keywords: script Cc:
Game: AGI Fanmade

Description

ScummVM 1.3.0svn54427 (Nov 23 2010 13:19:44)
Features compiled in: Vorbis FLAC MP3 RGB zLib Theora

The knife stuck in the crate is drawn in foreground (before ego even)
Which is wrong and looks like a tie on ego :-) (Screenshot attached)

Beyond the Titanic 2 (DOS/English)

AmigaOS4 - PPC - SDL - BE
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #3116686. Ticket imported from: bugs/5526.

Attachments (2)

AGI FAN Beyond the Titanic 2 - Priority Problem.png (8.6 KB) - added by raziel- 9 years ago.
It's the knife, not a tie
agi-fanmade-1.001 (1.8 KB) - added by digitall 8 years ago.
Savegame For Replication

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by raziel-

It's the knife, not a tie

comment:1 Changed 8 years ago by digitall

Replicated on Linux x86_32 with :
ScummVM 1.3.0git3507-g4a5b30e-dirty (Mar 1 2011 09:45:58)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora

Attaching savegame to aid replication.

Changed 8 years ago by digitall

Attachment: agi-fanmade-1.001 added

Savegame For Replication

comment:2 Changed 8 years ago by sev-

Could you reproduce it with NAGI?

comment:3 Changed 8 years ago by raziel-

Nagi v2.06

Reproduceable

comment:4 Changed 8 years ago by bluegr

This is a bug with the priority assigned to the knife in script 4 via set.priority: the knife's priority is set to a fixed priority of 11, while ego's priority remains dynamic. There's not much that can be done about this one, it's a design flaw of the game, and since this is a fanmade game, the game's author should fix that. Closing as "won't fix".

comment:5 Changed 8 years ago by bluegr

Keywords: script added
Owner: set to bluegr
Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.