Opened 9 years ago

Closed 9 years ago

#5503 closed defect (fixed)

QFG3: Crash when saving outside palace

Reported by: SF/l-w-c Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 3

Description

Using v1.1 of this game, I ran ScummVM (Windows) with -d 9 and it showed:
terminate called after throwing an instance of 'std::bad_alloc'
what(): std::bad_alloc

It happens whenever I try to save outside the palace (that is, in the very second screen of the game).

Ticket imported from: #3106107. Ticket imported from: bugs/5503.

Change History (7)

comment:1 by bluegr, 9 years ago

Summary: Crash when saving outside palacaQFG3: Crash when saving outside palace

comment:2 by bluegr, 9 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest SVN/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by SF/l-w-c, 9 years ago

* Daily from November 11, 2010, 8:12 am
* Start game, exit screen, save
* English
* Floppy (or at least not talkie)
* Win32
* I can't save there - this is the bug
* This is the first time ScummVM supports SCI

comment:4 by bluegr, 9 years ago

I managed to reproduce this. It only happens with Adlib. Seems to be somewhat related to music

comment:5 by bluegr, 9 years ago

It also occurs when saving at the first screen. When exiting the palace (either directly or after loading), the game hangs

comment:6 by bluegr, 9 years ago

Fixed in rc7bfbc3

comment:7 by bluegr, 9 years ago

Owner: set to bluegr
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.