Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5263 closed defect (fixed)

LB2: Pathfinding problems

Reported by: SF/escarlate Owned by: waltervn
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Laura Bow 2: The Dagger of Amon-Ra

Description

If Laura escapes to the reception room with the giant Ramses bust, the murderer eventually arrives there but doesn't kill her, the game stops responding and the top menu is disabled with the exception of the "?" icon help option. Also, if she closes the left exit in the pterodactyl room, she can't move until the doors are opened again. No console output in both cases, I attached a savegame below in the pterodactyl exhibit.

Game: Laura Bow 2: The Dagger of Amon Ra (CD/DOS/English)
Game Version: VGA CD v1.1
ScummVM Version: 1.2.0svn52134
OS: Win32 (XP SP2)

Ticket imported from: #3047418. Ticket imported from: bugs/5263.

Attachments (2)

laurabow2.001 (56.3 KB ) - added by SF/escarlate 9 years ago.
laurabow2-1.006 (49.9 KB ) - added by bluegr 9 years ago.
Savegame from bug #3050596

Download all attachments as: .zip

Change History (15)

by SF/escarlate, 9 years ago

Attachment: laurabow2.001 added

comment:1 by m-kiewitz, 9 years ago

Owner: set to waltervn

comment:2 by m-kiewitz, 9 years ago

just checked with youtube. Laura is supposed to run away. Problem is her pathfinding doesnt return anything, so she stays there and the murderer gets stuck on her. Assigning to walter.

comment:3 by bluegr, 9 years ago

Summary: LAURABOW2 CD: Act 5 lock-upLAURABOW2:

comment:4 by bluegr, 9 years ago

Summary: LAURABOW2:LB2: Pathfinding problems

comment:5 by bluegr, 9 years ago

Resolution: duplicate
Status: newclosed
Summary: LB2: Pathfinding problemsLAURABOW2 CD: Act 5 lock-up

comment:6 by bluegr, 9 years ago

Summary: LAURABOW2 CD: Act 5 lock-upLB2: Pathfinding problems

comment:7 by bluegr, 9 years ago

Merged duplicate bug #3048213 into this one. The saved game is the same. From that bug:

"Laura Bow 2: The Dagger of Amon Ra (CD/DOS/English), version 1.1
Laura Bow 2: The Dagger of Amon Ra (DOS/English), version 1.000
ScummVM 1.2.0svn52199

Situation: Laura enters mastodon skeleton room from the right
Bug: Laura takes weird u turn before resting on correct entry spot. No console output.

Attached savegame. Saved at start of weird motion, all movement shown before regaining control of the mouse is pathfinder weirdness."

comment:8 by bluegr, 9 years ago

Resolution: duplicate
Status: closednew

comment:9 by bluegr, 9 years ago

Merged duplicate bug #3050596 into this one. The saved game is in the same spot for the floppy version. From that bug:
"Laura Bow 2: The Dagger of Amon Ra (DOS/English), version 1.000
ScummVM 1.2.0svn52268

Situation: Beginning of Act 5, Laura is chased by murderer
Bug: Murderer chase animation stuck at left end of the room. If chase times out, murderer clubs Laura from that spot and Laura falls to the ground wherever she stands in the room."

by bluegr, 9 years ago

Attachment: laurabow2-1.006 added

Savegame from bug #3050596

comment:10 by bluegr, 9 years ago

And a video of the aforementioned bug:
http://www.youtube.com/watch?v=3kO0HTJ2UOs

comment:11 by bluegr, 9 years ago

All of these problems are caused by the same issue: we avoid plotting a path along screen edges in AStar() inside kpathing.cpp. This is different per game (e.g. if we disable that for LSL5, Patti walks through a wall in one scene). Disabling that code removes all of these bugs

comment:12 by waltervn, 9 years ago

Fixed by r54199 and r54230.

comment:13 by waltervn, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.