Opened 9 years ago

Closed 9 years ago

#5226 closed defect (invalid)

KQ4: faulty file dependency

Reported by: SF/noizje Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 4

Description

When ADL.DRV is not present, game crashes reporting "Sounddriver could not be loaded".
I am sure this file isn't loading anything into ScummVM.

Ticket imported from: #3043996. Ticket imported from: bugs/5226.

Change History (11)

comment:1 by lordhoto, 9 years ago

Owner: set to lordhoto
Resolution: invalid
Status: newclosed

comment:2 by lordhoto, 9 years ago

Looking at the source code of the SCI engine it turns out that the AdLib patch data is stored in ADL.DRV for some SCI games, thus ScummVM still requires that file, when you want to have AdLib sound.

comment:3 by lordhoto, 9 years ago

Owner: lordhoto removed
Resolution: invalid
Status: closednew

comment:4 by lordhoto, 9 years ago

I wanted to try it for myself, but KQ1 SCI doesn't even start for me. I asked clone2727 and he told me KQ1 SCI features a patch.003 resource though, that one is the resource where the AdLib patch data is stored usually as I got it, thus the code should never check whether ADL.DRV is present and use it. So this looks rather odd.

comment:5 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz

comment:6 by m-kiewitz, 9 years ago

Music without ADL.DRV works without problems in my KQ1. Maybe there is another version, that doesn't have patch 3. In that case ADL.DRV is needed.

Please read the VERSION file from your game directory and tell us what you got.

comment:7 by bluegr, 9 years ago

The Adlib driver loads instrument patches from patch.003. If this file doesn't exist in the game's resource files or on its own, then the SCI Adlib driver reads instrument data from ADL.DRV (which is where instrument data was embedded in SCI0 early games).

Since KQ1 is not SCI0 early, the most likely reason for this error would seem to be that this version isn't the PC version, but the Mac version, which doesn't have Adlib patches. Can you please provide a listing of your game's files, including sizes?

comment:8 by SF/noizje, 9 years ago

Oops my mistake, it is KQ4 not KQ1. I am so sorry for the mix-up.
I'll check for version numbers / file sizes when I am at home.

comment:9 by SF/noizje, 9 years ago

Game: King's Quest 1King's Quest 4
Summary: KQ1: faulty file dependencyKQ4: faulty file dependency

comment:10 by m-kiewitz, 9 years ago

Resolution: invalid
Status: newclosed

comment:11 by m-kiewitz, 9 years ago

nice find, i got confused by all the KQ1 mentioning as well. Closing now, KQ4 doesn't have patches, so ADL.DRV is of course needed for adlib sound.

Note: See TracTickets for help on using tickets.