Opened 9 years ago

Closed 9 years ago

Last modified 12 months ago

#5092 closed defect (fixed)

Changing OpenGL graphics mode from normal to 2x or 3x result

Reported by: SF/wickedshell Owned by: sev-
Priority: normal Component: Graphics: Scalers
Keywords: Cc:
Game:

Description

When testing the gsoc opengl branch r51580, under Linux, the render can be set to any OpenGL mode and will work fine, but when it is set to normal, a game is launched, then you select return to launcher from the menu, and select either OpenGL x2 or OpenGL x3 it will appear fine (4 out of 5 times, once I got a message saying I needed to restart scummvm) but when you launch a game it will hang then crash after having printed "Widget <GlobalConfig> has y < 0 (-8)!". The next time ScummVM is launched it will appear in the last selected OpenGL mode that casued it to crash.

Used DOTT as the game launched. As mentioned though the first time I tried to switch from normal to a higher multiplier it said scummvm must be restarted, it never showed that message again, despite having followed the same procedure.

Ticket imported from: #3037924. Ticket imported from: bugs/5092.

Change History (6)

comment:1 by SF/vgvgf, 9 years ago

I have not been able to reproduce the crash, tried many times, and it is working well. However, I am using a newer revision and not r51580. Can you try on latest revision?

comment:2 by SF/wickedshell, 9 years ago

As of r51774 (the one I got when I updated today :) the issue still exists. Is there some kind of profiling or recording I can do to help localize what's causing these errors?

I poured it through valgrind to see if it had any issues with it (I've had valgrind solve some problems faster then GDB before) and it had several memory leaks, and spat out a bunch of warnings about redirections depending upon uninitialized values. Some look graphics related and some don't, in any event I didn't see any obvious solutions but I'd be happy to drop the output of having run valgrind or other tools.

Any thing I can do to help track it down just let me know

comment:3 by SF/vgvgf, 9 years ago

I have fixed a problem regarding mode changes, could you test again if the error persists with the latest revision?

comment:4 by SF/wickedshell, 9 years ago

Sorry, was off on vacation. The error is gone, works beautifully now :) This can be closed...

comment:5 by sev-, 9 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:6 by digitall, 12 months ago

Component: Graphics: Scalers
Note: See TracTickets for help on using tickets.