Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5032 closed defect (wontfix)

SQ1VGA: Timing issues with drinking water on Kerona

Reported by: SF/kuroshiro Owned by: bluegr
Priority: normal Component: Engine: SCI
Keywords: original Cc:
Game: Space Quest 1

Description

Space Quest 1 (VGA/Dos/English) ScummVM 1.2.0SVN 51450 Windows 7 x64

On Kerona (the desert planet), if the speed slider is set too low (more than two clicks down from the top), you will be forced to drink water every few steps or you will die. This makes it pretty impossible to proceed. It can be fixed by turning the speed slider up to near the top (if you put it all the way up to the top Roger will just insta-teleport where you click to walk with no in-between animation).

Ticket imported from: #3036359. Ticket imported from: bugs/5032.

Change History (4)

comment:1 by SF/kuroshiro, 9 years ago

Update: Actually, it seems that after walking around on the surface long enough you will be forced to constantly drink water no matter what speed it is set to. This makes the game functionally impossible to complete in some situations since you have to lose the water eventually to continue, and you will generally die before you can proceed.

comment:2 by bluegr, 9 years ago

Also occurs in the original, you need to crank the speed slider fully up. This is a script bug, and is fixed completely with newrisingsun's script patches. Updated information in the known SCI bugs page: http://wiki.scummvm.org/index.php/SCI/Bugs

Closing

comment:3 by bluegr, 9 years ago

Keywords: original added
Owner: set to bluegr
Resolution: wontfix
Status: newclosed

comment:4 by bluegr, 9 years ago

Update on this bug: This is actually fixed in ScummVM now, and newrisingsun's patches aren't needed. I played SQ1VGA with all speed settings and couldn't reproduce this

Note: See TracTickets for help on using tickets.