Opened 9 years ago

Closed 9 years ago

#5022 closed defect (fixed)

PQ1VGA - Poker Game crashes at random moments on the script

Reported by: SF/sirdupre Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Police Quest 1

Description

The poker game in Hotel Delphoria crashes sometimes into the console with a message like: ERROR: [VM] kRandom[3c]: signature mismatch via method hand3::computerBet (script 156, room 156, localCall 0xffffffff)!

I've had the crash twice and finished the game afterwards by skipping the poker game, but it should be rather easy to reproduce.

Game Version: (VGA Remake/Dos/English)
ScummVM version: 1.2.0svn51367
Platform: Windows Vista Bussiness, Service Pack 1

Ticket imported from: #3036125. Ticket imported from: bugs/5022.

Attachments (1)

pq1sci.013 (43.2 KB ) - added by SF/sirdupre 9 years ago.
Savegame right before the poker game. Sit at the table to play.

Download all attachments as: .zip

Change History (9)

by SF/sirdupre, 9 years ago

Attachment: pq1sci.013 added

Savegame right before the poker game. Sit at the table to play.

comment:1 by m-kiewitz, 9 years ago

please add full debug output from console window (there should be some lines like "parameter x: ....". We need those

comment:2 by SF/sirdupre, 9 years ago

I loaded the game and played until I got the error. The complete console window shows the following:

User picked target 'pq1sci' (gameid 'sci')...
Looking for a plugin supporting this gameid... SCI Engine [SCI0, SCI01, SCI10,
SCI11, SCI32]
Starting 'Sierra SCI Game'
Emulating SCI version SCI1.1

WARNING: kDoSound(pause): Slot not found (0003:02bb)!
WARNING: Read for a parameter goes out-of-bounds, onto the stack and gets uninit
ialized temp!
WARNING: cmdDummy invoked!
WARNING: kDoSound(pause): Slot not found (0003:02bb)!
parameter 0: 0000:0003 (integer), should be null, integer
parameter 1: not passed, should be null, integer
[VM] kRandom[3c]: signature mismatch via method hand2::computerBet (script 156,
room 156, localCall 0xffffffff)!

comment:3 by m-kiewitz, 9 years ago

Component: Engine: SCI
Game: Police Quest 1
Owner: set to m-kiewitz
Resolution: fixed

comment:4 by m-kiewitz, 9 years ago

thank you

should have been fixed with r51435 (please try it out, i will leave this bug open)

comment:5 by SF/sirdupre, 9 years ago

I'll try it as soon as I can get that version (or newer) from the buildbot (current one is 51418). I'll let you know.

comment:6 by SF/sirdupre, 9 years ago

I've tried it in r51452 and I was able to play trough both poker games without crashing. Great, thanks for fixing it!

comment:7 by bluegr, 9 years ago

Since this bug appeears to have been fixed, I'm closing it. Thanks for reporting it

comment:8 by bluegr, 9 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.