Opened 9 years ago

Closed 9 years ago

#5007 closed defect (fixed)

PEPPER non-interactive demo: Crash

Reported by: SF/escarlate Owned by: lordhoto
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Pepper's Adventures in Time

Description

Experienced two different crashes. The first carsh was at the beggining, and the console spewed this out:

"WARNING: [resMan] Attempt to unlock non-existant resource message.100!
WARNING: [resMan] Attempt to unlock non-existant resource message.110!
Assertion failed: idx >= 0 && (uint)idx < _size, file ./common/array.h, line 164

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information."

The second time it went a little further, but eventually crashed with this messages:

WARNING: [resMan] Attempt to unlock non-existant resource message.100!
WARNING: [resMan] Attempt to unlock non-existant resource message.110!
WARNING: Read for a parameter goes out-of-bounds, onto the stack and gets uninit
ialized temp!
WARNING: [resMan] Attempt to unlock non-existant resource message.120!
WARNING: [resMan] Attempt to unlock non-existant resource message.140!
WARNING: [resMan] Attempt to unlock non-existant resource message.210!
WARNING: [resMan] Attempt to unlock non-existant resource message.600!
WARNING: [resMan] Attempt to unlock non-existant resource message.210!
WARNING: [resMan] Attempt to unlock non-existant resource message.345!
Uninitialized read for temp 0 from method Narrator::<noname 538> (script 928, lo
calCall ffffffff)!

Ticket imported from: #3035650. Ticket imported from: bugs/5007.

Change History (8)

comment:1 by SF/escarlate, 9 years ago

Oh, and I was using 1.2.0svn51397 in Windows XP SP2.

comment:2 by sev-, 9 years ago

Component: Engine: SCI
Game: Pepper's Adventures in Time

comment:3 by SF/mthreepwood, 9 years ago

Keywords: script removed

comment:4 by SF/mthreepwood, 9 years ago

There's some very evil things going on here. Here's what valgrind has to say:

WARNING: Read for a parameter goes out-of-bounds, onto the stack and gets uninitialized temp!
==677== Invalid read of size 8
==677== at 0x1009218BA: Sci::Object::operator=(Sci::Object const&) (in ./scummvm)
==677== by 0x1009153DE: Sci::kClone(Sci::EngineState*, int, Sci::reg_t*) (in ./scummvm)
==677== by 0x10093580F: Sci::callKernelFunc(Sci::EngineState*, int, int) (in ./scummvm)

comment:5 by lordhoto, 9 years ago

Owner: set to lordhoto
Resolution: fixed
Status: newpending

comment:6 by lordhoto, 9 years ago

The assertion should be fixed starting with revision 52561 and I could not reproduce the uninitialized read myself. I'll mark this report as pending.

When you expire the uninitialized read again please comment on this tracker item again, that should reopen it automatically.

comment:7 by bluegr, 9 years ago

Status: pendingclosed

comment:8 by bluegr, 9 years ago

I fixed the uninitialized read problem in an earlier revision, thus I'm closing this

Note: See TracTickets for help on using tickets.