Opened 9 years ago

Closed 9 years ago

#4994 closed defect (worksforme)

SCI: Volume control pauses introductions

Reported by: SF/graxer Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: EcoQuest 1

Description

I have noticed this issue in multiple SCI games ever since SCI support started, and although it may not be classed as a bug, it is an annoyance. During the introductions of the games, if you have a keyboard with volume controls, using them will pause the introduction and bring up the game menu. Games where this can be seen are:

EcoQuest: The Search for Cetus (Floppy/DOS/English)
Castle of Dr. Brain (DOS/English)
The Island of Dr. Brain (DOS/English)
Space Quest IV: Roger Wilco and the Time-Rippers (CD/DOS/English)
Space Quest V: The Next Mutation (DOS/English)

Ticket imported from: #3035389. Ticket imported from: bugs/4994.

Change History (11)

comment:1 by m-kiewitz, 9 years ago

My notebook's volume controls work just fine. I guess your keyboard and/or the keyboard drivers send something to the application. Pressing any key during the intro is supposed to pause it. Please try the same with dos-box just to make sure.

comment:2 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz
Resolution: worksforme

comment:3 by SF/graxer, 9 years ago

Just tested in DOSbox with EcoQuest 1 and Castle of Dr. Brain. The problem doesn't exist in DOSbox, just ScummVM.

comment:4 by m-kiewitz, 9 years ago

what OS are you using?
maybe DOS-Box is filtering something out or maybe ScummVM uses another way to get keyboard presses. In any case, the problem is the keyboard driver. Do you have any ability and knowledge to set a breakpoint?

comment:5 by SF/graxer, 9 years ago

I was using Windows 7. I just tried XP and encountered the same problem. However I also tested it on Ubuntu and the problem doesn't exist on there. It may just be a Windows problem.

I'm sorry, but im not experienced with C++, just the Java basics at the moment.

comment:6 by m-kiewitz, 9 years ago

I'm using Windows XP here and wasn't able to reproduce it. Like I said, it's either your keyboard driver, if you are using a special one, or its the actual keyboard/BIOS that is doing this. Pressing such keys shouldnt get passed to applications at all.

If I only knew what keys were sent to ScummVM. Maybe someone else is able to reproduce it.

comment:7 by SF/graxer, 9 years ago

It's just my laptop's keyboard at the moment. I will give an external keyboard a shot when I can. That may rule out the keyboard driver.

Just to check, when you go into "Volume Control" on XP, do your volume buttons make the master slider on the left move? That may show if ours have different functions.

comment:8 by m-kiewitz, 9 years ago

the master slider moves, yes

comment:9 by SF/graxer, 9 years ago

Ok, thanks for checking anyway!

comment:10 by sev-, 9 years ago

Component: Engine: SCI
Game: EcoQuest 1

comment:11 by sev-, 9 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.