Opened 9 years ago

Closed 9 years ago

#4924 closed defect (fixed)

SYMBIAN: Unexpected game cursor behavior

Reported by: SF/kumade Owned by: anotherguest
Priority: normal Component: Engine: Lure
Keywords: Cc:
Game: Lure of the Temptress

Description

ScummVM version : ScummVM 1.1.1
Platform and Compiler : Symbian 9.3 (Nokia n86 phone)
Version of game : vga \ dos (floppy) \ english, with lure.dat

Bug details : when use right button on some game object (this will open context window of any possible actions with this game object (like "Get", "Push", "Talk to" etc)) - mouse cursor freezes. So i cant select any actions for game object without doing some stupid things, like:
1- open scumm general menu (then cursor activates again), move cursor to the position, where ingame context window lays, close scumm general menu. And now i can move cursor inside ingame context menu and select actions. But if i will cross the border of context menu with cursor - it deactivates again.

2- i can imagine that cursor is still moving (but not drawing properly) and i can try to "blindly" move cursor inside the border of context menu. As soon as i hit this area with cursor - it activates inside the context menu borders and i can choose some action from it.

Other words, the problem is that cursor stops to render itself, when ingame context menu opens. It renders fine on whole screen, when no context menu opened, or it renders itself only inside the borders of context menu, when context menu is opened.
If context menu opens in same screen position, where the cursor currently resides - then no problem, but most of time it opens far away from cursor and its very inconvenient to choose actions from context menu.

if my description is incomprehensible (english is not my native language), devs, You can email me at
kumade(at)yandex.ru

Ticket imported from: #3030143. Ticket imported from: bugs/4924.

Change History (6)

comment:1 by SF/kumade, 9 years ago

Summary: Mouse cursor behaviorGame cursor behavior

comment:2 by sev-, 9 years ago

Owner: set to anotherguest
Summary: Game cursor behaviorSYMBIAN: Unexpected game cursor behavior

comment:3 by anotherguest, 9 years ago

Last I checked this, its a problem with how the rendering loop works, i.e no screen updates are called when the Lure menu is showing, so this should be fixed in Lure engine somehow. I might be able to propose a solution.

comment:4 by anotherguest, 9 years ago

Quick fix is to enable cursor mode (green, 8, green) to do you selection then back to mouse mode with green, 0, green

comment:5 by anotherguest, 9 years ago

Resolution: fixed
Status: newclosed

comment:6 by anotherguest, 9 years ago

Symbian is using LURE_CLICKABLE_MENUS define.
But the mouse cursor was only updated when inside the menu rectangle, and thus not updated properly.
Changed so screen is always updated when you move the mouse or click left mouse button, regardless of the position.

Note: See TracTickets for help on using tickets.