Opened 9 years ago

Closed 8 years ago

#4908 closed defect (fixed)

AGI: PQ1: Flickering newspaper

Reported by: eriktorbjorn Owned by: bluegr
Priority: high Component: Engine: AGI
Keywords: Cc:
Game: Police Quest 1

Description

Current ScummVM SVN
English AGI version of the game

I noticed that if I enter the briefing room at the beginning, pick up the newspaper (which automatically makes you read it) and click anywhere with the mouse, the graphics either begin to flicker, or it starts flipping rapidly through the pages. (It depends on where you click.) I get the impression (quite possibly wrong) that the engine is trying to have your character walk somewhere, which perhaps could be part of the problem?

Ticket imported from: #3018770. Ticket imported from: bugs/4908.

Change History (8)

comment:1 by m-kiewitz, 9 years ago

Summary: PQ1: Flickering newspaperAGI: PQ1: Flickering newspaper

comment:2 by sev-, 9 years ago

Owner: set to sev-

comment:3 by sev-, 9 years ago

The problem is that it continue to autogenerate left and right arrow clicks which turn the pages. I will look into it.

comment:4 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:5 by sev-, 9 years ago

Priority: normalhigh

comment:6 by eriktorbjorn, 9 years ago

This bug does not seem to happen in NAGI. (http://github.com/sonneveld/nagi)

comment:7 by bluegr, 8 years ago

Owner: changed from sev- to bluegr
Resolution: fixed
Status: newclosed

comment:8 by bluegr, 8 years ago

Fixed in r4070342

Note: See TracTickets for help on using tickets.