Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4888 closed defect (fixed)

SCI LSL3: Door slam sound incorporated in background music

Reported by: raziel- Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Leisure Suit Larry 3

Description

ScummVM 1.2.0svn49240 (May 26 2010 15:59:08)
Features compiled in: Vorbis FLAC MP3 RGB zLib

When Cherri Tart leaves the backstage there is a door slam sound played while background music is shortly silenced. After the door slam sound was played the slam sound is unfortunately incorporated in the background music and sounds like a too loud bass drum.

The same happens when Cherri enters backstage again

MIDI through MT-32 devcie

Leisure Suit Larry III (DOS/English)

AmigaOS4
gcc (GCC) 4.2.4 (adtools build 20090118)

Ticket imported from: #3007449. Ticket imported from: bugs/4888.

Attachments (1)

lsl3.004 (17.6 KB ) - added by raziel- 9 years ago.
Let the animation roll and listen

Download all attachments as: .zip

Change History (11)

by raziel-, 9 years ago

Attachment: lsl3.004 added

Let the animation roll and listen

comment:1 by raziel-, 9 years ago

This goes for all the doors in the game.
It even "Works" for the sliding sound of the elevator doors and slightly lower volume sound of the doors in Fat City

Seems to be a general music glitch

comment:2 by m-kiewitz, 9 years ago

hi there,

could you please try this again under latest revision? Also please enter debugger when watching this scene (press Ctrl-D) and then enter "room" as command. Please post the returned number in here.

comment:3 by m-kiewitz, 9 years ago

Owner: set to m-kiewitz

comment:4 by raziel-, 9 years ago

revision 49409

Issue still there, room (of the example in the .004 save game is) 420

comment:5 by m-kiewitz, 9 years ago

I was finally able to reproduce it now (saved games for sci0 were broken for some days) . It's happening, because the actual music is paused, the door slam music track is played, changes an instrument and then the actual music is resumed, resulting in the music using that instrument. Similar things happen in sci1, although those will get solved by implementing channel remapping. But in this case, it won't help.

comment:6 by m-kiewitz, 9 years ago

issue should be solved now - at least with mt32 emulation the door slam is played and music resumes fine afterwards.

For now on a real mt32 there may be issues like when music is resumed its actually playing "fast-forward", but those will get fixed as well.

Could you please try again?

comment:7 by raziel-, 9 years ago

Yes, fixed

btw, this "fast-forward" effect on the MT-32 happens with all SCI games aswell as soon as you load a game.
So it would be totally awesome if this can be fixed too (Maybe it will simply go away as soon as that effect is fixed?)

comment:8 by m-kiewitz, 9 years ago

Resolution: fixed
Status: newclosed

comment:9 by m-kiewitz, 9 years ago

fast-forward will get fixed sometime. We know about this "issue", but it's somewhat hard to fix. We are currently seeking to a position by passing all midi commands till that position immediately to the driver (this is common code, not sci specific). This means the mt32 will actually receive all midi commands immediately till seek position thus resulting in this "fast-forward" music. If we don't do anything at all, instruments etc. will be wrong.

We need to create a seeker, that actually handles all sorts of midi commands, remember the contents and then actually send the latest commands only to the driver.

comment:10 by sev-, 9 years ago

Component: Engine: SCI
Game: Leisure Suit Larry 3
Note: See TracTickets for help on using tickets.