Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4875 closed defect (invalid)

KYRA3: Assertion Error

Reported by: SF/nerva85 Owned by: lordhoto
Priority: high Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 3

Description

Scummvm 1.1.0 (also latest svn)
In the middle of the game (in Limbo, when you riding the water course and after being shot from the cannon) the following error occured:
Assertion Failed: fr >0, file sound/timestamp.cpp, line 40
I've tried to overwrite the .aud and .tlk as it was proposed in the forum but it didn't help.
English version
Win32

Ticket imported from: #2997464. Ticket imported from: bugs/4875.

Attachments (5)

kyra3.009 (16.9 KB ) - added by SF/nerva85 9 years ago.
kyra3.md5 (8.5 KB ) - added by lordhoto 9 years ago.
checksums.md5 (10.3 KB ) - added by SF/nerva85 9 years ago.
kyra3.026 (16.8 KB ) - added by lordhoto 9 years ago.
Save before cannon shot with gold coins and worms
kyr.txt (12.6 KB ) - added by SF/nerva85 9 years ago.

Download all attachments as: .zip

Change History (26)

by SF/nerva85, 9 years ago

Attachment: kyra3.009 added

comment:1 by SF/nerva85, 9 years ago

Summary: Assertion ErrorKYRA3: Assertion Error

comment:2 by lordhoto, 9 years ago

I can not reproduce this with my Kyrandia 3 copy.

You might also want to try copying over WESTWOOD.001 from your CD, that file also contains audio data.

I will also append a file containing all the md5sums of my Kyrandia 3 files, you might want to compare those with your version.

by lordhoto, 9 years ago

Attachment: kyra3.md5 added

comment:3 by SF/nerva85, 9 years ago

Thanks for md5, I will check this.
As for westwood.001 I've copied it before also and no effect.

comment:4 by lordhoto, 9 years ago

Owner: set to lordhoto

comment:5 by fingolfin, 9 years ago

What is the status of this item?

by SF/nerva85, 9 years ago

Attachment: checksums.md5 added

comment:6 by SF/nerva85, 9 years ago

Sorry for abandoning this item, but it's still the same. The md5 sums I've checked are the same (only the number of the files is bigger, my copy has 210 files, lordhoto's 192), I'll include my checksums also. So I don't know what can be done more.

comment:7 by lordhoto, 9 years ago

From your file list it looks like you installed the games first. That is not needed. I doubt it causes any problems though, will need to check that.

In any case I just added new new save game before the cannon shot (with some gold coins and worms in case you need them). Please try that one and tell me the exact steps with which you can reproduce this. I did not have any success in reproducing it so far.

by lordhoto, 9 years ago

Attachment: kyra3.026 added

Save before cannon shot with gold coins and worms

comment:8 by SF/nerva85, 9 years ago

Sorry to say but with your savefile it's still the same error (both cases: riding the water course and shooting from the cannon). I don't know what's happening :-(((

comment:9 by fingolfin, 9 years ago

Yeah, but what are the *exact* steps you take to trigger the crash? Please give a "guide for dummies", e.g. "1. Load the attached save, 2. click on X, 3. press key Y, 4. crash". Try to mention every detail.

comment:10 by SF/nerva85, 9 years ago

Ok, I loaded the save provided by lordhoto, so I'm on the screen with water course, cannon and fish. When I'm trying to go down to the dump on the water course one screen down just before Malcolm must fall down to the dump (I guess it's animation scene here) and crash!! Command prompt says "assertion failed...". The same is when I'm paying the fish with five coins and after Malcolm is being shot from the cannon and new screen must appear it crashes with the same error, so the new screen is not even appearing. By the way I copied all filles from another Kyrandia 3 cd and with the same result.

comment:11 by fingolfin, 9 years ago

Andriy, that's hardly a step-by-step guide of what you are doing!

In the meantime, I cannot reproduce the issue(s) either.

comment:12 by sev-, 9 years ago

Priority: normalhigh

comment:13 by sev-, 9 years ago

This bug is nice to get fixed before the release. Raising priority for keeping the track.

comment:14 by SF/nerva85, 9 years ago

Sorry for long delays between messages, being busy at work.
I try once more to reproduce the situation.
1. I load the save provided to me by lordhoto.
2. I click several time on the water course on top of the screen.
3. Malcolm is jumping inside.
4. Macolm starts going down on the water course.
5. The screen is changing to the screen with the dump.
6. Just before Malcolm coming to the dump, the game crashes.
7. Another crash with the same error message happens when Malcolm is being shot from the cannon.
8. This happens at the moment when the screen changes.
As I mentioned before I tried to copy all files from another Kyr3 CD but unfortunately with the same result.
Once more I'm sorry for long delay and my poor English.

comment:15 by lordhoto, 9 years ago

Ok I still cannot reproduce this.

I added some debug output to KYRA3's sound output now though. You need wait for the next daily build (i.e. the one from 14th September 2010) and then start it with the following command line parameters:

scummvm -d5 --debugflags=Sound kyra3

In case kyra3 is your Kyrandia 3 target.

Then please save all output you get on the console/terminal in a file and attach it on this tracker item.

comment:16 by SF/nerva85, 9 years ago

Here is the result. I copied it fro both cases, first for water course and then after shot from cannon.

by SF/nerva85, 9 years ago

Attachment: kyr.txt added

comment:17 by lordhoto, 9 years ago

Ok looks like your FALL1.AUD is corrupted, I checked your md5sum list again and it also differs to my FALL1.AUD (which I first had to extract from AUD.PAK). Your AUD.PAK md5sum matches mine though.

So I wonder why did you extract all the AUD files from AUD.PAK? And moreover what did you do to FALL1.AUD?

Anyway this is an invalid bug report, you should just remove all your game data files and copy them over from the original CD again and just copy WESTWOOD.001 along with it, instead of relying on a DOS installed game.

comment:18 by lordhoto, 9 years ago

Resolution: invalid
Status: newclosed

comment:19 by SF/nerva85, 9 years ago

This corruption with FALL1.AUD I mentioned also. The most interesting thing is that I have never extracted any files in game directory, I just copied the game files from iso image of the cd version of Kyr3 (two times from two different images). So let it be how it is....

comment:20 by SF/nerva85, 9 years ago

Sorry I wrote wrong thing. Not mentioned but noticed.

comment:21 by lordhoto, 9 years ago

Well it is your fault to use ISO images (which are usually a good indication for a downloaded thus illegal version and we do not give any support for that, see here: http://wiki.scummvm.org/index.php/Copyright_FAQ). Anyway it's definitely an invalid bug report then.

Note: See TracTickets for help on using tickets.