Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4870 closed defect (fixed)

FT: Cavefish Hideout Chase (Failure Cutscene) Crash

Reported by: SF/jfebland Owned by: lordhoto
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

ScummVM version 1.1.0 (downloaded yesterday)
Full Throttle Version A/English (installed from original CD)
ScummVM Windows 64bit (zipfile)
Windows 7

Game crashes at the same frame ("green light at the end of the tunnel") during the failure chase cutscene in the Cavefish hideout, after ramp is hitched to bike and the player clicks to exit the cave (without unhitching the ramp from the bike, as required to proceed). Generic crash message "http://www.scummvm.org/ has stopped working". Not a single other error experienced in the game so far.

Savefile instructions: load savefile, and simply click once on the tunnel to exit the cave. Cutscene will start, and game will crash after a few seconds.

Ticket imported from: #2995282. Ticket imported from: bugs/4870.

Attachments (2)

ft.s01 (23.7 KB ) - added by SF/jfebland 10 years ago.
Cavefish Hideout Chase Crash
bomp_fix.patch (2.0 KB ) - added by lordhoto 10 years ago.

Download all attachments as: .zip

Change History (16)

by SF/jfebland, 10 years ago

Attachment: ft.s01 added

Cavefish Hideout Chase Crash

comment:1 by SF/jfebland, 10 years ago

I should add, I was under the impression that the game was not completable in this state, and thus in conflict with Full Throttle's "playable to the end" status in this version's README, until I remembered that unhitching the ramp was required to progress. First-time players would probably think the game was not "playable to the end" and perhaps give up, as the crash occurs before failure (and the game thus letting you know to try something else).

comment:2 by SF/jfebland, 10 years ago

Priority: normalhigh

comment:3 by fingolfin, 10 years ago

Owner: set to Kirben
Summary: Reproducable Cavefish Hideout Chase (Failure Cutscene) CrashSCUMM HE: Cavefish Hideout Chase (Failure Cutscene) Crash

comment:4 by fingolfin, 10 years ago

Does this issue persist in 1.1.1?

comment:5 by SF/mthreepwood, 10 years ago

Summary: SCUMM HE: Cavefish Hideout Chase (Failure Cutscene) CrashFT: Cavefish Hideout Chase (Failure Cutscene) Crash

comment:6 by fingolfin, 10 years ago

Priority: highnormal
Summary: FT: Cavefish Hideout Chase (Failure Cutscene) CrashSCUMM HE: Cavefish Hideout Chase (Failure Cutscene) Crash

comment:7 by fingolfin, 10 years ago

Summary: SCUMM HE: Cavefish Hideout Chase (Failure Cutscene) CrashFT: Cavefish Hideout Chase (Failure Cutscene) Crash

comment:8 by SF/jfebland, 10 years ago

This issue persists in 1.1.1. I just tested it three times with the same result.

comment:9 by SF/mthreepwood, 10 years ago

I'm able to reproduce in the trunk. It looks like it crashes right after the cutscene trying to render a costume.

gdb backtrace (partial):

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x0000000000000000
0x00000001000265ef in Scumm::AkosRenderer::codec5 (this=0x103073600, xmoveCur=-66, ymoveCur=21) at engines/scumm/akos.cpp:1071
1071 bdd.actorPalette[i] = _palette[i];
(gdb) bt
#0 0x00000001000265ef in Scumm::AkosRenderer::codec5 (this=0x103073600, xmoveCur=-66, ymoveCur=21) at engines/scumm/akos.cpp:1071
#1 0x000000010002a990 in Scumm::AkosRenderer::drawLimb (this=0x103073600, a=0x10213fe00, limb=0) at engines/scumm/akos.cpp:527
#2 0x000000010002add4 in Scumm::BaseCostumeRenderer::drawCostume (this=0x103073600, vs=@0x10211e890, numStrips=41, a=0x10213fe00, drawToBackBuf=false) at engines/scumm/base-costume.cpp:58
#3 0x000000010001ff50 in Scumm::Actor::drawActorCostume (this=0x10213fe00, hitTestMode=false) at engines/scumm/actor.cpp:1540

comment:10 by lordhoto, 10 years ago

Looks like a regression from r43577 (16bit merge) to me.

Seeing the surrounding lines, bdd.actorPalette is always a NULL pointer.

I attached a possible fix for this, since I do not own FT I have no ways of testing it.

by lordhoto, 10 years ago

Attachment: bomp_fix.patch added

comment:11 by lordhoto, 10 years ago

According to salty-horse my patch works fine. I will close this bug report then.

The fix should be in the next nightly SVN build of ScummVM. Please test it and report whether you still have issues.

comment:12 by lordhoto, 10 years ago

Owner: changed from Kirben to lordhoto
Resolution: fixed
Status: newclosed

comment:13 by SF/gnober, 10 years ago

I'm not sure how to use the patch. I downloaded it, and put it into the ScummVM's patch folder, but I still get the same error. So either this patch doesn't work or I'm doing something wrong...

comment:14 by lordhoto, 10 years ago

You don't have to download the patch, but a daily build from http://scummvm.sourceforge.net/downloads/#SVN

Note: See TracTickets for help on using tickets.