Opened 10 years ago

Closed 9 years ago

#4854 closed defect (fixed)

SPYFOX3 (French): Crash when using the fingernail machine

Reported by: SF/lineplus Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Spy Fox 3

Description

Hello,
I use ScummVM 1.1 on Ubuntu 10.04 Beta. When I play Spy Fox 3: Operation Ozone (French) and I go on the fingernail machine (on the Venus moonbase), the game crashes. I tested also with ScummVM 1.0 and the SVN of the 7 April 2010, same bug. In the console, I get this message :

scummvm: engines/scumm/he/palette_he.cpp:206: void Scumm::ScummEngine_v90he::setHEPaletteFromImage(int, int, int): Assertion `rgbs\' failed.
Abandon

I have attached a picture showing how to reproduce the bug. I don\'t know which files are save files, but I can send them if you say which. I play with files copied on my computer from a CD-Rom borrowed in a library.

PS : Sorry if my english is bad, I am french.

Ticket imported from: #2984000. Ticket imported from: bugs/4854.

Attachments (1)

bug.jpg (296.0 KB ) - added by SF/lineplus 10 years ago.

Download all attachments as: .zip

Change History (13)

by SF/lineplus, 10 years ago

Attachment: bug.jpg added

comment:1 by SF/lineplus, 10 years ago

The attached image with a better quality : http://img44.xooimage.com/files/0/1/7/bug-1aca9e5.png

comment:2 by SF/lineplus, 10 years ago

I misspoke : it's not the Venus moonbase, it's the Poodle moonbase (Venus is her name in the french version).

comment:3 by SF/lineplus, 10 years ago

And when I said the Poodle moonbase, I meant the moonbase of Poodle...

comment:4 by Kirben, 10 years ago

This problem seems to be specific to the French version, as I'm unable to reproduce the problem in the English version.

comment:5 by SF/lineplus, 10 years ago

Ok.
I will re-borrow the game at the library Tuesday and play from the CD to see if it bugs also.
I saw it on the wiki : http://wiki.scummvm.org/index.php/Humongous_Entertainment/Games/Debug_Modes but I do not see hegames.ini... Do you know where is this file, please ?

comment:6 by Kirben, 10 years ago

hegames.ini is usually stored in the Windows directory (ie c:\windows\) but might be redirected to another location (ie C:\Users\username\AppData\Local\VirtualStore\Windows) , if UAC is enabled under Windows Vista/7.

comment:7 by SF/lineplus, 10 years ago

Thank you, but I am on Ubuntu.

Hegames.ini is usable only when I play using the original Windows executable (not with ScummVM) ?

comment:8 by Kirben, 10 years ago

Yes, hegames.ini is only used by the original Windows executable.

To enable the debug modes under ScummVM, start ScummVM with a debug level of 1 or higher:
ie scummvm -d1 spyozon

comment:9 by SF/lineplus, 10 years ago

Thank you.

Here is what appears at the precise moment of the crash, with a debug level of 1 :

(38:3:0xC): DEBUG: Setting Current Pool
(38:3:0x3AD): DEBUG: whichPool = 15
(38:3:0x650): DEBUG: Inside else - not resetting pool?
(38:3:0x6CE): DEBUG: killCurrentSong = 0
(38:2055:0x7A69): DEBUG: starting ambient sound 1546
(38:2069:0x9E42): DEBUG: Color 248
scummvm: engines/scumm/he/palette_he.cpp:206: void Scumm::ScummEngine_v90he::setHEPaletteFromImage(int, int, int): Assertion `rgbs' failed.
Abandon (core dumped)

But, at the line DEBUG: Color 248 , it's not a fix number : sometimes, I have 67, 0, 255...
It's helpful ?

comment:10 by Kirben, 9 years ago

Component: Engine: SCUMM
Game: Spy Fox 3

comment:11 by Kirben, 9 years ago

Fixed in ScummVM SVN, use the next daily snapshot of ScummvM SVN.

The setHEPaletteFromPtr () function is only used, if the RGB block exists, in the original version.

comment:12 by Kirben, 9 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Summary: Spy Fox 3 (French): Crash on going on the fingernail machineSPYFOX3 (French): Crash when using the fingernail machine
Note: See TracTickets for help on using tickets.