Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4812 closed defect (fixed)

DW2: Weird "PC SPEAKER-like" sound distortion.

Reported by: SF/jinx1337 Owned by: fingolfin
Priority: high Component: Engine: Tinsel
Keywords: Cc:
Game: Discworld II

Description

Apart from the sound stuttering from time to time, there are random, loud PC-Speaker like sounds that occur throughout the game.

They occur in the newest SVN nightly build.

I've recorded a video of this issue:

http://img707.imageshack.us/i/file22676.mp4/

Ticket imported from: #2969282. Ticket imported from: bugs/4812.

Change History (9)

comment:1 Changed 9 years ago by SF/jinx1337

Summary: PSP: Weird "PC SPEAKER-like" sound distortion.DW2 PSP: Weird "PC SPEAKER-like" sound distortion.

comment:2 Changed 9 years ago by SF/bobdevis

This is not a PSP exclusive bug.
I have this happening on my x86_64 Kubuntu 9.10 box with 1.1.0 svn 47985 too.
I didn't report this because I thought it was a Puleaudio issue.

comment:3 Changed 9 years ago by fingolfin

Owner: set to dreammaster
Priority: normalhigh

comment:4 Changed 9 years ago by fingolfin

Does this already happen in 1.0.0? If not, it's a serious regression and should be treated with high priority.

comment:5 Changed 9 years ago by SF/bobdevis

I guess I'll stuff my bug report here then since I'm sure I have the same issue.

Engine and OS versions
--------------------------------
Bug does NOT occur Linux Kubuntu 9.04 64bit with 1.0.0-1

Bug DOES occur on Linux Kubuntu 9.04 64bit with the 1.1.0 svn 47985

Bug does NOT occur on Windows XP32 1.1.0pre 48232, or at least occurs very rarely.
I managed to get the sound glitch ONCE while I was mashing escape to skip the intro while testing.
I run my XP in VMWare so I am not 100% it was the bug or a VMWare glitch.

Bug Details
----------------
Sometimes 'bad data' is send off to be played as audio. It could be an annoying beep or some form of static noise.
Sometimes some sounds (pretty sure this only applies to voices) is not send to to be played at all. The subtitles display but you don't hear them speak. They 'skip' a sentence.
The command-line gives no error messages in any case.

How to reproduce
------------------------
When the 'beep' or the 'line skipping' occurs is pretty random. You can't reproduce it exactly the same way twice.
The beep occurs more frequently when you just entered a scene.
The line skipping occurs a lot less frequent then the beep. You just have to talk a lot to characters to see it happen.

comment:6 Changed 9 years ago by eriktorbjorn

There appears to have been some breakage (not necessarily *the* breakage, of course) between r47739 and r47740. I'm much too sleepy to figure out why right now, though.

comment:7 Changed 9 years ago by fingolfin

Owner: changed from dreammaster to fingolfin
Resolution: fixed
Status: newclosed
Summary: DW2 PSP: Weird "PC SPEAKER-like" sound distortion.DW2: Weird "PC SPEAKER-like" sound distortion.

comment:8 Changed 9 years ago by fingolfin

Great work, Torbjörn. Fixed the bug in SVN (and of course it was my fault all along *sigh*).

comment:9 Changed 9 years ago by SF/bobdevis

I can confirm the bug is GONE in scummvm-20100313 from the Helllabs mirror.
It WAS there in scummvm-20100312.

Note: See TracTickets for help on using tickets.