Opened 10 years ago

Closed 10 years ago

#4753 closed defect (invalid)

DOTT: Messages appear for a very long time

Reported by: SF/tpwrules Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

When a message appears (the ones with white text on a black background, ie. Meanwhile... and Later that day...), it stays on screen for ~1 minute rather than ~3 seconds like it is supposed to. I am using v1.0.0 on Mac OS X 10.5.8. Included is a save file which shows this problem. Use the coins in your inventory with the dryer and the message should stay on for a very long time. This is DoTT CD English. A friend using the exact same data files does not have this problem.

Ticket imported from: #2933567. Ticket imported from: bugs/4753.

Attachments (1)

tentacle.s14 (33.9 KB ) - added by SF/tpwrules 10 years ago.
Example

Download all attachments as: .zip

Change History (5)

by SF/tpwrules, 10 years ago

Attachment: tentacle.s14 added

Example

comment:1 by SF/tpwrules, 10 years ago

Summary: Messages appear for a very long timeDOTT: Messages appear for a very long time

comment:2 by eriktorbjorn, 10 years ago

For whatever reason VAR_CHARINC (which at least is a big part in determining how long text should stay on the screen) is 255 in that savegame. In my own old savegames, it's 3.

Using the + or - key to adjust subtitle speed causes ScummVM to crash because the value is out of range. I was able to press F5 and open the Options dialog. In my case, the "Subtitle speed" was 2. Simply pressing Ok without changing anything was enough to update VAR_CHARINC. I guess changing it to 3 would be closer to what I have in my old savegames. (Apparently, the setting in the configuration file overrides what's in the savegame, because I had to remove the setting to be able to reproduce the error again.)

Of course, this doesn't explain how the variable got that value in the first place. The options dialog doesn't seem to allow it to go higherar than 9.

comment:3 by SF/tpwrules, 10 years ago

Well I somehow got it to go to 255. I opened the game settings and it said ..5, but when I adjusted it, it could go up to 255. How it got there, who knows. Thanks!

comment:4 by fingolfin, 10 years ago

Owner: set to eriktorbjorn
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.