Opened 11 years ago

Closed 11 years ago

#4743 closed defect (fixed)

Teenagent: Inventory problems on BE systems

Reported by: SF/avianauthority Owned by: SF/megath
Priority: normal Component: Engine: TeenAgent
Keywords: Cc:
Game: TeenAgent

Description

This only seems to happen when playing the game on the Wii console. I don't get the problem with Linux or Windows builds of ScummVM. A bit of cut and paste from the forum where I made a post already. I can't describe it any better.

It's when you need to use an inventory item. The first instance is showing the guard at the sentry hut your pass. The second instance is using a key on a door from inside the cell. I've only tried those 2. So to use the pass on the guard you would move the pointer to the top to reveal the inventory. Put the pointer over the pass and the text "pass" appears. Right-click the pass for the text "pass &". Move the pointer over the guard for the text "pass & guard".

It's that last part which is the problem. I get the text "pass & guard" but when I click on the guard then the text "guard" appears and my pass is back in my inventory.
I can't seem to use Inventory items.

I know the second instance where the inventory is used is the cell because I got past the pass/guard part by using a save made on my Linux PC (and then copied over to the SD card) which was made just after the guard let's me through. I can get the text "key & door" up but when I click the door the text changes to "door" and the key is back in my inventory.

I don't think it's a controller issue as I tried 2 different Wiimotes, a Wavebird and a normal wired Gamecube pad.

I'm using the free version of Teenagent from Good 'Ole Games. I've tried this with a number of builds of ScummVM for Wii downloaded from Buildbot. Latest being r 47013. By the way if this bug is passed to Dhewg - I think there's a little problem with the 'meta.xml' description file as well in that it doesn't have the actual description anymore. I'm talking about the file that the HBChannel uses. It loads fine, it's just the description of ScummVM is missing.

Ticket imported from: #2926655. Ticket imported from: bugs/4743.

Change History (6)

comment:1 by SF/megath, 11 years ago

Owner: set to SF/megath

comment:2 by SF/megath, 11 years ago

please update scummvm to version greater than r47069 and test again.

comment:3 by SF/avianauthority, 11 years ago

Just tried with r47215. No difference. Still can't use Inventory items.

comment:4 by hkzlab, 11 years ago

This is not wii only. I have the same problem on Nintendo64 port (BE, like the Wii). It looks like the problem is endian-related.

comment:5 by joostp, 11 years ago

Same problem indeed occurs on other big endian systems. Should be fixed as of r47236 (tested on PS3).

comment:6 by joostp, 11 years ago

Resolution: fixed
Status: newclosed
Summary: Wii (only) - Teenagent - InventoryTeenagent: Inventory problems on BE systems
Note: See TracTickets for help on using tickets.